Re: stm32f4_disco issues


Pushpal Sidhu
 

Hello Erwan,

Thanks for the help; the CONFIG_GPIO_STM32_PORTD was missing. I'll
send a PR to add this to stm32f4_disco_defconfig later today.

Regarding debugging, I was using debug before, but was running into
the same thing. I think it was purely because Zephyr itself was hung.

I can now use debug, but am still going to use debugserver so I can
use external tools. FWIW, I have the STLink/V2, so the initial config
worked for me.

Thanks again,
- Pushpal

On Thu, Oct 12, 2017 at 4:33 AM, Erwan Gouriou <erwan.gouriou@linaro.org> wrote:
Hi Pushpal,


Regarding the blinky issue. It's happening since CONFIG_GPIO_STM32_PORTD is
not activated.
You should add it in board defconfig.

Then, regarding the debug issue.
Have you tried make BOARD=stm32f4_disco debug ?
This should be working.

Just take care that you might have some dependency depending on the STLINK
firmware on your board.
Current openocd support in zephyr for this board should only work on
STLINK-V2.

On my side, I have a STLINK-V2.1 firmware and I had to do some changes to
get it working:
In
zephyr-sdk/sysroots/x86_64-pokysdk-linux/usr/share/openocd/scripts/board/stm32f4discovery.cfg
+source [find interface/stlink-v2-1.cfg]
-source [find interface/stlink-v2.cfg]
But then, worked directly.

HIH

Erwan


On 11 October 2017 at 23:38, Pushpal Sidhu <psidhu.devel@gmail.com> wrote:

Hi All,

I'm attempting to flash the samples/basic/blinky/ project on the
stm32f4_disco board, but am running into issues.

Here's a list of steps I run through:
make BOARD=stm32f4_disco -C samples/basic/blinky/
make BOARD=stm32f4_disco -C samples/basic/blinky/ flash

Then nothing happens on board (no LED blink after power cycle). I
attempt to debug
make BOARD=stm32f4_disco -C samples/basic/blinky/ debugserver
gdb -tui -ex "target remote :3333" ../outdir/stm32f4_disco/zephyr.elf

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ../outdir/stm32f4_disco/zephyr.elf...done.
Remote debugging using :3333
warning: Architecture rejected target-supplied description
warning: Cannot convert floating-point register value to
non-floating-point type.
value has been optimized out
0x00000000 in ?? ()
(gdb) run
The "remote" target does not support "run". Try "help target" or
"continue".
(gdb) continue
Continuing.
^Cwarning: Cannot convert floating-point register value to
non-floating-point type.
value has been optimized out

Program received signal SIGINT, Interrupt.
0x0800133d in _main ()
at /home/psidhu/src/zephyr/zephyr-upstream/kernel/init.c:190
190 {

It seems like execution is always stuck on _main(), but I don't know
why. Does anyone have any idea what's going on / if I'm doing
something wrong?

Thank you,
- Pushpal
_______________________________________________
Zephyr-devel mailing list
Zephyr-devel@lists.zephyrproject.org
https://lists.zephyrproject.org/mailman/listinfo/zephyr-devel

Join devel@lists.zephyrproject.org to automatically receive all group messages.