cmake error when I tried to build "mesh_shell"


Kai Ren
 

Hi there,

I had ever cmake and make “sample/Bluetooth/mesh” application today, get the corresponding hex file, I just make my MacBook laptop sleep for a while and didn’t change anything, I can’t build again.

 

MacBook-Pro-2:pca10040 renkai$ cmake -DBOARD=nrf52_pca10040 ..

CMake Error at CMakeLists.txt:1 (include):

  include could not find load file:

 

    /cmake/app/boilerplate.cmake

 

 

CMake Error at CMakeLists.txt:5 (target_sources):

  Cannot specify sources for target "app" which is not built by this project.

 

 

CMake Warning (dev) in CMakeLists.txt:

  No cmake_minimum_required command is present.  A line of code such as

 

    cmake_minimum_required(VERSION 3.10)

 

  should be added at the top of the file.  The version specified may be lower

  if you wish to support older CMake versions for this project.  For more

  information run "cmake --help-policy CMP0000".

This warning is for project developers.  Use -Wno-dev to suppress it.

 

-- Configuring incomplete, errors occurred!

See also "/Users/renkai/Documents/Work/git/zephyr/tests/bluetooth/mesh_shell/pca10040/CMakeFiles/CMakeOutput.log".

 

I thought there may be some errors in ./cmake folder, so I tried to rebuild it, then:

$ cd $ZEPHYR_BASE

$ cd build

$ cmake $ZEPHYR_BASE/scripts

but there are still some errors, it seems like some packages missing.

MacBook-Pro-2:zephyr renkai$ cd build/

MacBook-Pro-2:build renkai$ cmake ../scripts/

-- Checking for modules 'gtk+-2.0;libglade-2.0'

--   No package 'gtk+-2.0' found

--   No package 'libglade-2.0' found

-- Skipped building gconf since GTK dependencies were not met.

-- Found unsuitable Qt version "" from NOTFOUND

-- Skipped building qconf since QT dependencies were not found.

-- Configuring done

-- Generating done

-- Build files have been written to: /Users/renkai/Documents/Work/git/zephyr/build

 

so, I want to know, what wrong with it? And this phenomenon had ever been my Windows laptop before.

 

Regards,

Kai

 

 

 

Join devel@lists.zephyrproject.org to automatically receive all group messages.