Re: cmake error when I tried to build "mesh_shell"

Kai Ren

Hi Sebastian,
You're correct, after add ZEPHYR_BASE, GCCARMEMB_TOOLCHAIN_PATH and ZEPHYR_GCC_VARIANT into ~/.bash_profile, it can work on MacBook.

Hi Timothy,
Thank you for your help!


-----Original Message-----
From: Bøe, Sebastian []
Sent: Wednesday, November 29, 2017 5:09 PM
To: Timothy <>; Kai Ren <>
Subject: Re: [Zephyr-devel] cmake error when I tried to build "mesh_shell"

Hi Kai,

the first few lines in your error message means you are affected by this issue:
From: <> on behalf of Timothy <>
Sent: Wednesday, 29 November 2017 9:41:29 AM
To: Kai Ren
Subject: Re: [Zephyr-devel] cmake error when I tried to build "mesh_shell"

Hi Kai,

It looks like there are no errors on your 2nd pass.
Those are just warnings caused by CMake not finding Qt (in suitable version) and GTK libraries.
If you are not planning to build xconfig or gconfig target you can simply skip them.

This step has produced you a project build folder (called build) Now you have to do an additional step and actually build the project.

To do that use one of the following commands:
- cmake --build build
- ninja -C build
- make -C build


On 29 November 2017 at 08:36, Kai Ren <<>> wrote:
Hi there,
I had ever cmake and make "sample/Bluetooth/mesh" application today, get the corresponding hex file, I just make my MacBook laptop sleep for a while and didn't change anything, I can't build again.

MacBook-Pro-2:pca10040 renkai$ cmake -DBOARD=nrf52_pca10040 ..

CMake Error at CMakeLists.txt:1 (include):

include could not find load file:


CMake Error at CMakeLists.txt:5 (target_sources):

Cannot specify sources for target "app" which is not built by this project.

CMake Warning (dev) in CMakeLists.txt:

No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 3.10)

should be added at the top of the file. The version specified may be lower

if you wish to support older CMake versions for this project. For more

information run "cmake --help-policy CMP0000".

This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!

See also "/Users/renkai/Documents/Work/git/zephyr/tests/bluetooth/mesh_shell/pca10040/CMakeFiles/CMakeOutput.log".

I thought there may be some errors in ./cmake folder, so I tried to rebuild it, then:
$ cd build
$ cmake $ZEPHYR_BASE/scripts
but there are still some errors, it seems like some packages missing.

MacBook-Pro-2:zephyr renkai$ cd build/

MacBook-Pro-2:build renkai$ cmake ../scripts/

-- Checking for modules 'gtk+-2.0;libglade-2.0'

-- No package 'gtk+-2.0' found

-- No package 'libglade-2.0' found

-- Skipped building gconf since GTK dependencies were not met.

-- Found unsuitable Qt version "" from NOTFOUND

-- Skipped building qconf since QT dependencies were not found.

-- Configuring done

-- Generating done

-- Build files have been written to: /Users/renkai/Documents/Work/git/zephyr/build

so, I want to know, what wrong with it? And this phenomenon had ever been my Windows laptop before.


Zephyr-devel mailing list<>

Tim Kielan
Registered Linux User #239184

vim [noun] - lively or energetic spirit; enthusiasm; vitality

Join to automatically receive all group messages.