Re: Eddystone on nrf51 / nrf52


Vinayak Kariappa <vinayak.kariappa@...>
 

Can you check if the gcc library being linked is from arm6v-m? This is when if you use CROSS_COMPILE.



On 11 Mar 2017, at 08:48, Marcus Shawcroft <marcus.shawcroft@...> wrote:


On Sat, 11 Mar 2017 at 06:40, Johan Hedberg <johan.hedberg@...> wrote:
Hi Marcus,

On Fri, Mar 10, 2017, Marcus Shawcroft wrote:
> I've just tried samples/bluetooth/eddystone on nrf51 (bbc_microbit)
> and so far as I can tell it doesn't boot as far as main().
>
> Same experiment on nrf52 (pca10040) runs just fine.
>
> Is edddystone expected run on nrf51, has anyone ever tried it?

It is expected to run. I've been mainly using nRF51 USB dongles, but I
just tried the eddystone sample on my micro:bit and it's working fine.
How do you flash yours? I remember I had some strange issues with the
original debug IC firmware, and switching to a JLink one made it better.

Interesting.  I can still build various other samples and flash them to the microbit and they run just fine. I used a microbit fairly extensively a while back when putting together drivers for its I2C, magnetometer, accelerometer, TRNG etc and recall on one or two occasions getting it in a state where it would not flash using the vanilla daplink firmware. Iirc that cleared by power cycling both host and microbit. I also recall that switching to newlib instead of minimal Libc with BT enabled on the microbit results in a similar failure to reach main(). 

Johan would you mind sending me your microbit Eddystone configure file and the git hash of the dev tree that you just tested as working?

Cheers
/Marcus
_______________________________________________
Zephyr-devel mailing list
Zephyr-devel@...
https://lists.zephyrproject.org/mailman/listinfo/zephyr-devel

Join devel@lists.zephyrproject.org to automatically receive all group messages.