Re: Build fails when the sdk is not installed in the default path in Archlinux.


Yannis Damigos
 

On 02/23/2016 09:07 PM, Perez-Gonzalez, Inaky wrote:
On Mon, 2016-02-22 at 11:27 -0800, Dirk Brandewie wrote:

On 02/22/2016 09:59 AM, Yannis Damigos wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

On 02/22/2016 07:26 PM, Dirk Brandewie wrote:


On 02/22/2016 08:42 AM, Yannis Damigos wrote:
On 02/22/2016 05:10 PM, Dirk Brandewie wrote:


On 02/20/2016 07:50 AM, Yannis Damigos wrote:
Dear all,

Building the philosophers sample fails when the sdk is not
installed under the default path (/opt/zephyr-sdk) in
Archlinux with the following error:
make[1]: Entering directory
'/home/xekarfwtos/projects/zephyr'
make[2]: Entering directory
'/home/xekarfwtos/projects/philosophers/outdir'
Using /home/xekarfwtos/projects/zephyr as source for
kernel
GEN ./Makefile
CHK include/generated/version.h
HOSTCC scripts/basic/fixdep
HOSTCC scripts/gen_idt/version.o
HOSTCC scripts/gen_idt/gen_idt.o
HOSTLD scripts/gen_idt/gen_idt
HOSTCC scripts/gen_offset_header/gen_offset_header.o
HOSTLD scripts/gen_offset_header/gen_offset_header
CHK misc/generated/configs.c
UPD misc/generated/configs.c
i586-poky-elf-gcc: error trying to exec 'cc1': execvp: No
such file or directory
/home/xekarfwtos/projects/zephyr/./Kbuild:98: recipe for
target 'arch/x86/core/offsets/offsets.o' failed
make[3]: *** [arch/x86/core/offsets/offsets.o] Error 1
/home/xekarfwtos/projects/zephyr/Makefile:892: recipe for
target 'prepare' failed
make[2]: *** [prepare] Error 2
make[2]: Leaving directory
'/home/xekarfwtos/projects/philosophers/outdir'
Makefile:169: recipe for target 'sub-make' failed
make[1]: *** [sub-make] Error 2
make[1]: Leaving directory
'/home/xekarfwtos/projects/zephyr'
/home/xekarfwtos/projects/zephyr/Makefile.inc:61: recipe
for target 'all' failed
make: *** [all] Error 2
Is ZEPHYR_SDK_INSTALL_DIR pointing to the SDK install
directory?

When the sdk is installed under the default path compiling
succeeded.

Best regards,
Yannis
Yes, ZEPHYR_SDK_INSTALL_DIR is pointing to the correct SDK
install directory.
Hmmm :-/ Can you send the output of the make command adding V=1
to the
command line?
Here it is https://gist.github.com/xekarfwtos/78d9c85f018ed2a0ce4bYou could
Hmm looks like an SDK issue :-( I have created a bug for it
https://jira.zephyrproject.org/browse/ZEP-65

I don't have any more useful advice unfortunately.
Yannis can you provide an trace log?

$ strace -fo trace.log make ... [ETC ETC] ...

Thanks,
You could find the trace log uploaded under the issue ZEP-65 in jira:

https://jira.zephyrproject.org/browse/ZEP-65

Yannis

Join devel@lists.zephyrproject.org to automatically receive all group messages.