[RFC] File naming conventions in /drivers/subsystem folders


Tseng, Kuo-Lang <kuo-lang.tseng@...>
 

Hi,

Problem
*******
The current file naming of most files in /drivers/subsystem folders starts
with 'subsystem_something.[hc]'. The prefix part 'subsystem_' can seem to be
redundant as the subfolder where the file is located already namespaces
it.

e.g.
drivers/adc/adc_dw.[ch]

Proposed changes
***************
Remove the prefix 'subsystem_' from the filename. For example, some current
naming:

drivers/adc/adc_dw.[ch]
drivers/adc/adc_qmsi.c
drivers/spi/spi_k64.c
drivers/spi/spi_dw.c
drivers/spi/spi_qmsi.c
...

would become:

drivers/adc/dw.[ch]
drivers/adc/qmsi.c
drivers/spi/k64.c
drivers/spi/dw.c
drivers/spi/qmsi.c

One side effect would be that now you would end up having files with same
filenames from different folder (e.g. qmsi.c). This may not be an issue if each
resides in their own folder.

Comments/concerns welcome.

Thanks,
Kuo, Inaky

Join devel@lists.zephyrproject.org to automatically receive all group messages.