Re: QEMU networking: CONFIG_NET_TESTING breaks things, echo_server IPv6 address is "wrong"

Paul Sokolovsky

Hello Jukka,

On Fri, 19 Aug 2016 14:37:10 +0300
Jukka Rissanen <jukka.rissanen(a)> wrote:


Patches for these items can be now found in
I appreciate all the improvements done to networking documentation and
testing setup via the above and other patches during this week. There're
also some further concerns/issues, which I initially shared in
post-review comments to ,
and would like to duplicate here so they weren't lost:

* QEMU-host networking now works out of the box, but changes for that
regressed QEMU-QEMU case. I attempt to fix that in , but it needs review for
changes it does regarding NETWORKING_WITH_15_4 option.

* #4199, #4200 above went to "net" branch. Any ETA/plan for merging
them to master? My guess they went to "net" to avoid (incomplete)
changes soon before 1.5.0 release, but would be nice to get an
official ack.

* Finally, the latest one: I tried QEMU networking with qemu_cortex_m3,
and it doesn't work where qemu_x86 does. Which makes me wonder if
networking with qemu_cortex_m3 is supported/known to have worked at

Paul | Open source software for ARM SoCs
Follow Linaro:!/linaroorg -

Join to automatically receive all group messages.