Re: gpio pin configuration.


Marcus Shawcroft <marcus.shawcroft@...>
 

On 16 December 2016 at 09:52, Tomasz Bursztyka
<tomasz.bursztyka(a)linux.intel.com> wrote:

It was just a naming proposal, instead of:

GPIO_DS_0_HIGH
GPIO_DS_0_DISCONNECT
and
GPIO_DS_1_HIGH
GPIO_DS_1_DISCONNECT

we would have:
GPIO_DS_DFLT_HIGH (or *_DEFAULT_*)
GPIO_DS_DFLT_DISCONNECT

and:
GPIO_DS_ALT_HIGH (or *_ALTERNATE_*)
GPIO_DS_ALT_DISCONNECT

Of course my naming proposal is bogus. If I understand, should it be
GPIO_DS_OUTPUT_<LOW/HIGH or 0/1>_<HIGH/DISCONNECT> or?

It's just the _0_ and _1_ alone that are not telling anything by themselves.
Understood.

_low_ _high_ does make sense.

Cheers
/Marcus

Join devel@lists.zephyrproject.org to automatically receive all group messages.