On Thu, Jan 19, 2017, Marcus Shawcroft wrote:
Does "correct" in this case have any practical significance? It worsensThe right format specifier for unsigned integers is %u and not %d, so asSince the type is 'uint32_t' rather than 'unsigned' the correct specifier is:
the readability of the code quite a lot IMO, so if the significance is
purely theoretical it's a quite high price to pay for correctness. I've
used the PRI* macros in other projects, but never for anything smaller
than 64 bit integers.