Re: printf -> /dev/ttyXXX output not working (nRF52 DK, Thingy52)

Lars Knudsen

Hi Vinayak,

I have only connected the debug/flashing cable (see picture below). I thought the UART was part of that but of course, if it's going to different connectors, I can see why nothing appears ;)

I didn't find anywhere in the docs or via google searches that I would need more than the link cable.  If it's the case, I'll just see if I can map the printk/f -> SEGGER_RTT (for now)



On Thu, Jul 26, 2018 at 2:28 PM Chettimada, Vinayak Kariappa <vinayak.kariappa.chettimada@...> wrote:

Hi Lars,


I am assuming you have connected (wire) the configured Tx and Rx lines from your Thingy52 board to the DK’s TXD (P0.06) and RXD (P0.08) lines, at the least for the UART?





From: devel@... [mailto:devel@...] On Behalf Of Lars Knudsen
Sent: Thursday, July 26, 2018 11:28 AM
To: Zephyr-devel@...
Subject: [Zephyr-devel] printf -> /dev/ttyXXX output not working (nRF52 DK, Thingy52)




I recently got an nRF52 DK board to flash/debug Nordic Thingy52 using Zephyr.


My host machine is running Ubuntu Linux (modemmanager uninstalled, udev rules allows user access to the nRF52 DK).


According to documentation, printf statements fired from the Zephyr firmware on the Thingy52 (possibly printk - tried both) should end in the USB CDC output from the nRF52 DK.


I read that there might be an issue with HW flow control being enabled on the nRF52 DK so I tried multiple combinations enabling/disabling flags in minicom - but still no output.


SEGGER_RTT_Write works in combination with JLinkRTTConsole & JLinkExe with the following params:


JLinkExe -device NRF52832_XXAA -if SWD -speed 12000 -autoconnect 1


However, it would be nice with some basic printf -> /dev/ttyACM0 working.


Does anyone have some hints on possible missing build flags, includes, settings on nRF52 DK or other that might get the serial communication working?




Join to automatically receive all group messages.