Re: 回复:回复:[Zephyr-devel] hciconfig tools error with nrf52832 running zephyr


Maureen Helm
 

From: sxzxchen@... <sxzxchen@...>
Sent: Monday, August 27, 2018 11:52 AM
To: Johan Hedberg <johan.hedberg@...>
Cc: Maureen Helm <maureen.helm@...>; devel@...
Subject: 回复:回复:[Zephyr-devel] hciconfig tools error with nrf52832 running zephyr

 

ohsorry that I missed the dot.it is 4.1.15 actually

发自我的华为手机



-------- 原始邮件 --------
题:Re: 回复:[Zephyr-devel] hciconfig tools error with nrf52832 running zephyr
发件人:Johan Hedberg
收件人:sxzxchen@...
抄送:Maureen Helm ,devel@...


Earlier you said it was 4.1.15. Which one was a typo? :)

Johan

On Tue, Aug 28, 2018, sxzxchen@... wrote:
> imx6ullwith linux kernel version 4.15
>
> 发自我的华为手机
>
>
> -------- 原始邮件 --------
> 题:Re: [Zephyr-devel] hciconfig tools error with nrf52832 running zephyr
> 发件人:Maureen Helm
> 收件人:sxzxchen@...,Johan Hedberg
> 抄送:devel@...
>
>
>
>
> Which NXP device are you running embedded Linux? I can check to see if we
> have plans to update the kernel version.
>
>
>
> From: devel@... On
> Behalf Of sxzxchen@...
> Sent: Monday, August 27, 2018 7:28 AM
> To: Johan Hedberg
> Cc: devel@...
> Subject: Re: [Zephyr-devel] hciconfig tools error with nrf52832 running
> zephyr
>
>
>
> Thanks for your explanation.since the embedded linux version is bound with
> the chip, I cannot update it easily.So is there any ways to solve this
> problem without updating linux version ?
>
>
>
>
>
>
>
> At 2018-08-24 13:24:28, "Johan Hedberg" wrote:
>
> >Hi,
>
> >
>
> >On Thu, Aug 23, 2018, sxzxchen@... wrote:
>
> >> I bought a official nrf52832 development kits and ported zephyr
>
> >> project successfully. It runs fine with my ubuntu host,via btattach
>
> >> and btmgmt tools.But it didn't work with my nxp embedded linux,the
>
> >> linux version is 4.1.15 and supports hciattach hciconfig tools
>
> >> only.When I tried to bring the bluetooth module up with hciconfig hci0
>
> >> up,an error comes up:
>
> >
>
> >The 4.1 kernel is too old to support controllers without a public
>
> >address. IIRC you need at least a 4.4 kernel, but ideally something much
>
> >newer than that.
>
> >
>
> >Johan
>
>
>
>
>
>
>

Join devel@lists.zephyrproject.org to automatically receive all group messages.