Re: [Zephyr-users] assertion fail in nordic nrf5 i2c driver

Manu R

Thanks, I'll check it out.

On Wed, Oct 10, 2018 at 8:39 PM Marco Tozzini <lists@...> wrote:
Hi Manu,
I think I had the same problem and solved using the process showed here.


On October 9, 2018 12:03:01 PM PDT, Manu R <manu@...> wrote:
Carles, I am trying to use 1.13 and am having some issues. I can build hello_world, but when i tried to build anything with i2c, I have issues. ( drivers__i2c was created without source files)

build (master) $ ninja

[0/1] Re-running CMake...

CMake Warning at /Users/manurao/temp/zephyr/cmake/app/boilerplate.cmake:167 (message):

  The build directory must be cleaned pristinely when changing boards

Call Stack (most recent call first):

  CMakeLists.txt:3 (include)

-- Selected BOARD nrf52_pca10040

Zephyr version: 1.13.99

Parsing Kconfig tree in /Users/manurao/temp/zephyr/Kconfig

Loading /Users/manurao/temp/zephyr/samples/hello_world/build/zephyr/.config as base

CMake Warning at /Users/manurao/temp/zephyr/cmake/toolchain.cmake:48 (message):

  gccarmemb is deprecated, please use gnuarmemb instead

Call Stack (most recent call first):

  /Users/manurao/temp/zephyr/cmake/app/boilerplate.cmake:269 (include)

  CMakeLists.txt:3 (include)

-- Generating zephyr/include/generated/generated_dts_board.h

-- Cache files will be written to: /Users/manurao/Library/Caches/zephyr

CMake Error at ../../CMakeLists.txt:544 (message):

  The Zephyr library 'drivers__i2c' was created without source files.  Empty

  (non-imported) libraries are not supported.  Either make sure that the

  library has the sources it should have, or make sure it is not created when

  it has no source files.

-- Configuring incomplete, errors occurred!

See also "/Users/manurao/temp/zephyr/samples/hello_world/build/CMakeFiles/CMakeOutput.log".

See also "/Users/manurao/temp/zephyr/samples/hello_world/build/CMakeFiles/CMakeError.log".


/usr/local/Cellar/cmake/3.11.0/bin/cmake -H/Users/manurao/temp/zephyr/samples/hello_world -B/Users/manurao/temp/zephyr/samples/hello_world/build

ninja: error: rebuilding '': subcommand failed

build (master) $ 

On Tue, Oct 9, 2018 at 12:58 AM Cufi, Carles <Carles.Cufi@...> wrote:

Hi Manu,


The I2C driver has since been completely rewritten to use nrfx, our common driver codebase.

Would it be possible for you to try with current master (or at least 1.13) to see if you still face the issues you mention?




From: users@... <users@...> On Behalf Of Manu R
Sent: 08 October 2018 18:56
To: devel@...; users@...
Subject: [Zephyr-users] assertion fail in nordic nrf5 i2c driver


Hi all, 

I am using a lis2dh12 with a nrf52840, and am on occasion seeing an assertion. 

It happens in the i2c_nrf5_read


err=0 txd=0 rxd=0 stopped=0 errsrc=0x0

ASSERTION FAIL [data->stopped] @ <snip>/zephyr_new/drivers/i2c/i2c_nrf5.c:142:


We are based off of 5890004ea72066fb4b1e8100bb289fb5a00646a5 ( r 1.12)


Can someone shed light on whats happening? It looks like I am waiting for the EVENTS_STOPPED to hit in the isr, but seeing the data->stopped is not set, perhaps its not?

Are there any remedies? It looks like this condition should be benign, am I mistaken?




Sent from my Android device with K-9 Mail. Please excuse my brevity.

Join to automatically receive all group messages.