Re: [RFC] k_poll_signal name and MISRA
I think this was just a typo __toggle quoted messageShow quoted text
On 25/10/2018, 21:39, "email@example.com on behalf of Abderrezak Mekkaoui" <firstname.lastname@example.org on behalf of email@example.com> wrote:
First thing that came to my mind when I saw k_pll is a PLL. Hopefully
there is a better abbreviation for poll than pll.
On 10/25/2018 4:06 PM, Flavio Ceolin wrote:
> Hi guys,
> MISRA-C rule 5.7 says that a tag name shall be a unique identifier, also
> reuse tag names is an undefined behavior recognized in C99 (Section
> It happens that we have in Zephyr both a struct and a function called
> k_poll_signal (there may be others cases in the project), the question
> is, what it is preferable, change the function to something like,
> k_pll_signal_signal() or change the struct nam ? In the latter, what is the
> suggestion ? Remembering that I'll follow this pattern if necessary.
> Flavio Ceolin