Re: [RFC] k_poll_signal name and MISRA
toggle quoted messageShow quoted text
Making different names is good, but then I think one should be able to identify quickly which is struct and which isn't,
What about k_struct_poll_signal or k_poll_signal_struct ?
MISRA-C rule 5.7 says that a tag name shall be a unique identifier, also
reuse tag names is an undefined behavior recognized in C99 (Section
It happens that we have in Zephyr both a struct and a function called
k_poll_signal (there may be others cases in the project), the question
is, what it is preferable, change the function to something like,
k_pll_signal_signal() or change the struct nam ? In the latter, what is the
suggestion ? Remembering that I'll follow this pattern if necessary.
Join firstname.lastname@example.org to automatically receive all group messages.