Re: Getting started with ARM GNU Compiler | errors | #gettingstartedguide


Hi Sebastian,

I tried deleting build folder and created again.
Compilation successful without any issues. Issue not seen anymore

Balasubramanyam Rangineni

On Fri, Nov 16, 2018 at 9:23 PM Bøe, Sebastian <Sebastian.Boe@...> wrote:
I can't think of any reason why blinky would work, whilst hello_world
would produce that error.

Could you try again after deleting the build directories?

It is not necessary to add --specs=nosys.specs when the variant is set to gnuarmemb.

From: devel@... <devel@...> on behalf of Balasubramanyam <rangineni.balu@...>
Sent: Friday, November 16, 2018 4:48:20 PM
To: marti@...
Cc: devel@...
Subject: Re: [Zephyr-devel] Getting started with ARM GNU Compiler | errors | #gettingstartedguide

Hi Marti,

I tried compiling zephyr\samples\hello_world\ project.
I used camke command to compile
    cmake -GNinja -DBOARD=nrf52832_mdk ..

Failure seen after this command itself. But when I tried compiling blinky project I did not see any issue.

On Fri, Nov 16, 2018 at 9:10 PM Marti Bolivar <marti@...<mailto:marti@...>> wrote:

Is this an upstream sample project? What command lines did you use for
cmake and building the project itself?

On Thu, Nov 15, 2018 at 9:55 PM <rangineni.balu@...<mailto:rangineni.balu@...>> wrote:
> Hi Team,
> I am just getting started with Zephyr and trying to setup development environment. I followed all the steps described to setup ARM GNU GCC toolchain and compilation ENV.
> After setting up everything required, I got the following error after trying to compile a sample project.
> "
> CMake Error at ../../cmake/extensions.cmake:1086 (message):
>   Assertion failed: The toolchain is unable to build a dummy C file.  See
>   CMakeError.log.
> Call Stack (most recent call first):
>   ../../CMakeLists.txt:28 (assert)
> -- Configuring incomplete, errors occurred!
> See also "../zephyr/samples/hello_world/build/CMakeFiles/CMakeOutput.log".
> See also "../zephyr/samples/hello_world/build/CMakeFiles/CMakeError.log".
> ""
> I went through the log files  and it seems build failed at following
> ""
> The output was:
> 1
> c:/gnu_arm_embedded/bin/../lib/gcc/arm-none-eabi/7.3.1/../../../../arm-none-eabi/lib\libc.a(lib_a-exit.o): In function `exit':
> exit.c:(.text.exit+0x2c): undefined reference to `_exit'
> collect2.exe: error: ld returned 1 exit status""
> Seems ARM compiler issue, after bit of google found out that these options "--specs=nosys.specs" needs to be passed as command line params to run gcc.
> I am not able to figure out where i can exactly instruct build environment to use these command line options for GCC.
> I have attached both error and output log.
> Any help will be appreciated to be able to compile a project successfully.
> Thanks,
> Balasubramanyam Rangineni

Thanks & Regards,
Rangineni Balasubramanyam

Thanks & Regards,
Rangineni Balasubramanyam

Join to automatically receive all group messages.