Re: FATAL ERROR: 2 The system cannot find the file specified None 2 None #gettingstartedguide


Marcio Montenegro
 

The same problem occurs using the nxp kw41z board and windows 10

On Wed, Jan 2, 2019 at 10:31 AM <Bo.Kragelund@...> wrote:
Hi,

I have followed the getting started guide and installed zephyr, GNU, and tools on a Windows 7 machine and now trying to build and flash the "hello_world" sample.

I'm following the guidelines for the supported NXP FRDM-K64F board.
Since I'm using jlink for flashing, which is not default, I use below cmake command:
cmake -GNinja -DOPENSDA_FW=jlink -DBOARD=frdm_k64f ..
This command executes without any errors.

Then I use below command for making the elf file and flash the board.
ninja flash
This also runs without errors until the actual flashing. See output from cmd window below:
[103/109] Linking C executable zephyr\zephyr_prebuilt.elf
Memory region         Used Size  Region Size  %age Used
           FLASH:       12676 B         1 MB      1.21%
            SRAM:        4012 B       192 KB      2.04%
        IDT_LIST:          88 B         2 KB      4.30%
[108/109] Flashing frdm_k64f
Using runner: jlink
Flashing Target Device
FATAL ERROR: 2 The system cannot find the file specified None 2 None
run as "west -v ... flash ..." for a stack trace

I believe all my environment variables are set correct for using GNU compiler:
GNUARMEMB_TOOLCHAIN_PATH=C:\gnu_arm_embedded
ZEPHYR_BASE=c:\zephyr\zephyr\
ZEPHYR_TOOLCHAIN_VARIANT=gnuarmemb

I can flash the elf file using the J-Flash Lite without any problems, so I beleive hardware and windows drivers are fine.

I hope somebody can help me fix this basic issue.

Best regards,
Bo

Join devel@lists.zephyrproject.org to automatically receive all group messages.