Minimum required CMake version is not 3.13.1


Nashif, Anas
 

Hi,

 

We have changed the minimal requirement version of cmake to 3.13.1 meaning that you are required to update cmake on your system to build Zephyr.

 

Please follow the documentation below to satisfy the requirements:

 

https://docs.zephyrproject.org/latest/getting_started/installation_linux.html#install-requirements-and-dependencies

 

The reasons for a recent version of CMake is explain here:

 

https://github.com/zephyrproject-rtos/zephyr/pull/12022#issuecomment-446589193

 

We have a few requests to include CMake in the SDK, this is something we are considering in the new SDK based on crosstools-ng.

 

Regards,

Anas

 

Join devel@lists.zephyrproject.org to automatically receive all group messages.