Increasing minimum Zephyr Python version?


Marti Bolivar <marti@...>
 

Hi everyone,

I recently saw this while running test cases for west in Shippable:

DEPRECATION: Python 3.4 support has been deprecated. pip 19.1 will be
the last one supporting it. Please upgrade your Python as Python 3.4
won't be maintained after March 2019

At what point do we think we might want to move up to at least 3.5?
Are there any developers of Python code in the Zephyr tree who feel
hamstrung by limitations in Python 3.4?

Thanks,
Marti

Join devel@lists.zephyrproject.org to automatically receive all group messages.