Re: LE pair disconnected


Thea Aldrich
 

Hi Tommy,
I wanted to circle back around to make sure you were able to get your questions answered. If not, please let me know and I will help get you the answers you need. 

If you have not done so already, you can join our Slack channel where most of the developers and maintainers are available. It is a great place to ask questions and talk to the community.
Best,
Thea Aldrich


On Mon, Mar 18, 2019 at 6:01 AM Tommy Lin (林志聰) <Tommy.Lin@...> wrote:

Hi Johan,

sorry to bother you again.

We try to launch Bluetooth service.

After typing “systemctl status bluetooth.service” , some error messages as following:

Could you give us some suggestions.

 

Thank You,

Tommy

From: Tommy Lin (林志聰)
Sent: Wednesday, March 13, 2019 8:19 PM
To: 'Hedberg, Johan' <johan.hedberg@...>; 'Chettimada, Vinayak Kariappa' <vinayak.kariappa.chettimada@...>
Cc: Isaac Chen (
陳尚航) <Isaac_Chen@...>; 'Ryan Erickson' <Ryan.Erickson@...>; 'Jamie Mccrae' <Jamie.Mccrae@...>; 'zephyr-devel@...' <zephyr-devel@...>; 'Hanyu.Hsu@...' <Hanyu.Hsu@...>; Ryan Hsu (徐振鋒) <Ryan.Hsu@...>
Subject: RE: [Zephyr-devel] LE pair disconnected

 

Sorry,

I also add bluetoothd file to /usr/libexec/bluetooth/

 

Thanks

Tommy

From: Tommy Lin (林志聰)
Sent: Wednesday, March 13, 2019 8:14 PM
To: 'Hedberg, Johan' <johan.hedberg@...>; Chettimada, Vinayak Kariappa <vinayak.kariappa.chettimada@...>
Cc: Isaac Chen (
陳尚航) <Isaac_Chen@...>; Ryan Erickson <Ryan.Erickson@...>; Jamie Mccrae <Jamie.Mccrae@...>; zephyr-devel@...; Hanyu.Hsu@...; Ryan Hsu (徐振鋒) <Ryan.Hsu@...>
Subject: RE: [Zephyr-devel] LE pair disconnected

 

Hi Johan,

Thanks for your information

 

I do following things:

1.     add Bluetooth.service file to /lib/systemd/system/bluetooth.service

2.     add bluetooth.conf file to /etc/dbus-1/system.d

 

and start Bluetooth service , but it is still auto disconnection after connection.

 

Could you continue to give us some suggestions

 

Thank You,

Tommy

-----Original Message-----


From: Hedberg, Johan [mailto:johan.hedberg@...]
Sent: Wednesday, March 13, 2019 4:55 PM
To: Chettimada, Vinayak Kariappa <vinayak.kariappa.chettimada@...>
Cc: Tommy Lin (
林志聰) <Tommy.Lin@...>; Isaac Chen (陳尚航) <Isaac_Chen@...>; Ryan Erickson <Ryan.Erickson@...>; Jamie Mccrae <Jamie.Mccrae@...>; zephyr-devel@...; Hanyu.Hsu@...; Ryan Hsu (徐振鋒) <Ryan.Hsu@...>
Subject: Re: [Zephyr-devel] LE pair disconnected

 

Hi,

 

The Linux kernel has a 2 second timeout for any connection that doesnt have users. Users in this context are e.g. any user space sockets that use the connection. Normally when bluetoothd is running it owns the ATT socket, so theres always at least one user. It sounds to me like Tommy might not have bluetoothd or any other GATT server running. Anyway, this is starting to be a bit off-topic for the Zephyr mailing list.

 

Johan

 

> On 13 Mar 2019, at 10.50, Chettimada, Vinayak Kariappa <vinayak.kariappa.chettimada@...> wrote:

>

> Hi Tommy,

> Sorry, I am not able to try out your usecase on Bluez, as it has been quite sometime that I have been using with Bluez, due to my priorities, you may have to wait or ask someone else on the maillist to investigate the reasons for the host to disconnect the link.

> I am suspecting that you are not running at client that subscribes to a service, and hence the lost host decides to disconnect the idle link.

> Regards,

> Vinayak

> From: Tommy Lin (林志聰) <Tommy.Lin@...>

> Sent: 13 March 2019 08:41

> To: Chettimada, Vinayak Kariappa <vinayak.kariappa.chettimada@...>; Isaac Chen (陳尚航) <Isaac_Chen@...>; Ryan Erickson <Ryan.Erickson@...>; Jamie Mccrae <Jamie.Mccrae@...>; zephyr-devel@...

> Cc: Hanyu.Hsu@...; Ryan Hsu (徐振鋒) <Ryan.Hsu@...>

> Subject: RE: [Zephyr-devel] LE pair disconnected

> Hi Vinayak,

> sorry to bother you again.

> In your experience , what reason will cause CONNECTION TERMINATED BY LOCAL HOST

> > HCI Event: Disconnect Complete (0x05) plen 4                                                                                                                                                                          

>         Status: Success (0x00)

>         Reason: Connection Terminated By Local Host (0x16)

> @ MGMT Event: Device Disconnected (0x000c) plen 8                                                                                                                                                             

>         LE Address: 7A:03:05:31:E7:E6 (Resolvable)

>         Reason: Connection terminated by local host (0x02)

> <image001.png>

> Thank You,

> Tommy

> From: Tommy Lin (林志聰)

> Sent: Tuesday, March 5, 2019 11:29 AM

> To: 'Chettimada, Vinayak Kariappa' <vinayak.kariappa.chettimada@...>; Isaac Chen (陳尚航) <Isaac_Chen@...>; 'Ryan Erickson' <Ryan.Erickson@...>; 'Jamie Mccrae' <Jamie.Mccrae@...>; 'zephyr-devel@...' <zephyr-devel@...>

> Cc: 'Hanyu.Hsu@...' <Hanyu.Hsu@...>; Ryan Hsu (徐振鋒) <Ryan.Hsu@...>

> Subject: RE: [Zephyr-devel] LE pair disconnected

> Hi Vinayak,

> btmon logs has been put in Attachment.

> Thank You.

> Tommy

> From: Chettimada, Vinayak Kariappa [mailto:vinayak.kariappa.chettimada@...]

> Sent: Monday, March 4, 2019 3:50 PM

> To: Isaac Chen (陳尚航) <Isaac_Chen@...>; Tommy Lin (林志聰) <Tommy.Lin@...>; Ryan Erickson <Ryan.Erickson@...>; Jamie Mccrae <Jamie.Mccrae@...>; zephyr-devel@...

> Cc: Hanyu.Hsu@...; Ryan Hsu (徐振鋒) <Ryan.Hsu@...>

> Subject: Re: [Zephyr-devel] LE pair disconnected

> Hi,

> Could you please provide the btmon HCI logs?

> Regards,

> Vinayak

> From: "Isaac Chen (陳尚航)" <Isaac_Chen@...>

> Date: Monday, 4 March 2019 at 8:01 AM

> To: "Tommy Lin (林志聰)" <Tommy.Lin@...>, Ryan Erickson <Ryan.Erickson@...>, Jamie Mccrae <Jamie.Mccrae@...>, Vinayak Chettimada <vinayak.kariappa.chettimada@...>, "zephyr-devel@..." <zephyr-devel@...>

> Cc: "Hanyu.Hsu@..." <Hanyu.Hsu@...>, "Ryan Hsu (徐振鋒)" <Ryan.Hsu@...>

> Subject: RE: [Zephyr-devel] LE pair disconnected

> Hi Zephyr team,

> We can find this issue on nRF51 DK and our custom board with zephyr source code(samples/bluetooth/hci_uart). Could you give us your advice on how to solve this issue?

> Best Regards

> Isaac Chen

> Quanta Computer Inc.

> Business Unit 11 BL1

> Tel  : +886-3-327-2345 Ext : 17585

> This transmission is intended only for the use of the addressed recipient and may contain information that is privileged, confidential and exempt from disclosure under applicable law. If you are not the intended recipient, any use of this communication is strictly prohibited. If you have received this communication in error, please kindly notify the sender and delete this message immediately.

> From: Tommy Lin (林志聰)

> Sent: Wednesday, February 27, 2019 4:03 PM

> To: Ryan Erickson; Jamie Mccrae; Isaac Chen (陳尚航); Chettimada, Vinayak Kariappa; zephyr-devel@...

> Cc: Hanyu.Hsu@...; Ryan Hsu (徐振鋒)

> Subject: [Zephyr-devel] LE pair disconnected

>  

> Hi Ryan Erickson,

> We use zephyr source code(samples/bluetooth/hci_uart) , and type following commands:

> After then , we can find out device(named 2019bt) in our phone , and we can pair it.

> But 2019bt will be disconnected after about two second at connected.

> Could you give us some suggestions

> Thank  You.

> <image002.jpg>

 

Join devel@lists.zephyrproject.org to automatically receive all group messages.