Re: ninja guiconfig fail #gettingstartedguide


Bolivar, Marti
 

Hi,

"hotkernel via Lists.Zephyrproject.Org"
<hotkernel=163.com@...> writes:

Hi Carles,
Thank you for reminding me that the guiconfig was introduced after the release of Zephyr 1.14 at master.
So if use the git clone to get the source code not by the west tool (git clone https://github.com/zephyrproject-rtos/zephyr.git source2)
then I can launch "ninia guiconfig" under the build directory.
It doesn't matter how you get the source code; west will work too.
The important thing is that you need something more recent than LTS for
this new feature.

If you run plain "west init" it will pull the latest zephyr master --
you would actually have to specify additional arguments not to get the
latest, as in "west init --mr v1.14.0".

If you previously cloned zephyr v1.14 and want to update to a later
version, you can use "git pull". Just make sure to run "west update"
after each git pull to update your modules. As has been discussed on
other threads in this list, new modules are being added often right now
as zephyr/ext is cleared out, and your build will break if you don't
keep the up to date.

Thanks,
Marti



Join devel@lists.zephyrproject.org to automatically receive all group messages.