Re: [EXT] [Zephyr-devel] Help flashing nxp MIMXRT1050-EVKB


Andrei Gansari
 

Hello Flavio,

From what you describe, most probably you have an old version of SEGGER JLink on your host machine. I have the following version on my machine:
SEGGER J-Link Commander V6.46c (Compiled Jun 3 2019 18:32:22)
DLL version V6.46c, compiled Jun 3 2019 18:31:31
Please check your host's version of JLink (e.g. JLinkExe - Linux/ JLink Commander - Windows)

There maybe other issues such as:
- debugger FW (looks like you use a generic firmware, there is a board and hyperflash specific version of the firmware)
- dip switches on board

Regards,
Andrei Gansari

-----Original Message-----
From: devel@lists.zephyrproject.org <devel@lists.zephyrproject.org> On Behalf Of Flavio Ceolin via Lists.Zephyrproject.Org
Sent: Tuesday, July 23, 2019 6:54 PM
To: zephyr-devel@lists.zephyrproject.org
Cc: devel@lists.zephyrproject.org
Subject: [EXT] [Zephyr-devel] Help flashing nxp MIMXRT1050-EVKB

Caution: EXT Email

I'm trying to flash this board following our documentation with no success. I've being installed the OpenSDA_V2_1.bin firmware but when I try to flash I get the following error:

J-Link connection not established yet but required for command.
Connecting to J-Link via USB...O.K.
Firmware: J-Link OpenSDA 2 compiled May 27 2019 11:01:03 Hardware version: V1.00
S/N: 621000000
VTref=3.300V
Target connection not established yet but required for command.
The selected device "MCIMXRT1052" is unknown to this version of the J-Link software.

---

I've tried both, stable and beta J-Link tools. Someone have seen or know how to fix problem ?

Regards,
Flavio Ceolin

Join devel@lists.zephyrproject.org to automatically receive all group messages.