Re: Issue in OTA of zephyr OS over UART on Nordic nrf52840_pca10056 chip #bluetoothmesh #ble #nrf52840 #uart

Adam Podogrocki

Hi Mayank,

If you are sure the partition layout of flash memory is correct and you flashed MCUboot and SMP_SVR sample respectively, then please check if the CONFIG_UART_MCUMGR_ON_DEV_NAME is set correctly.


On Tue, 5 Nov 2019 at 15:15, Mayank <mayank7117@...> wrote:

I have nrf52840 on my custom board (Based on IMX6, Running Yocto linux) which is connected over UART.
I want to do an OTA of zephyr OS on that chip over serial/ble and for that i had already tried following things.
1) I have build smp_svr and flashed it to nrf52840 so that i can use 'mcumgr' command line tool for the flashing.
Referred to know how to use 'mcumgr'.

Now, when i use mcumgr to communicate 'hello' message over serial/UART, It shows error of connection timed out. (Also tried with -t switch, but no luck).
Command used are :
sudo mcumgr --conntype serial --connstring='dev=/dev/ttymxc0,baud=115200' echo hello
--> So it's not able to open the connection using mcumgr and not getting any reply (Getting timeout).

Join to automatically receive all group messages.