Re: hci interface stopped working after few hours #ble #hci #nrf52480 #uart


Hi Vinayak,

> Are you using any host debugger firmware to convert to USB? or using 3v TTL connections to your custom board from nRF52840?

When I tested it, it was using an nRF52840 PCA10059-like board without a 32KHz crystal (RC was selected from zephyr), I also tried on a BL654 DVK with the 32KHz connected and set in zephyr


> For those using USB_UART conversion, I am assuming you are using Segger JLink firmware on the host chip in the nRF52840 DK/dongle. Could you try using the MBED firmware on the host debugger chip?

When I was testing the UART one, I used an FTDI chip so this does not apply. I tested against a BT850 module, which also uses an FTDI with a non-zephyr based HCI module and that worked flawlessly


> Also, please create or refer me to GH issue, so that further discussions can be continued there.

I never created an issue. I haven’t tested in probably about a year now or so.


Join to automatically receive all group messages.