Re: hci interface stopped working after few hours #ble #nrf52480 #uart #hci


Chettimada, Vinayak Kariappa
 

Hi, Both Mayank and Jamie,

 

I am interested in the way the HCI packets are transported to the Host Bluetooth stack.

 

In case of use of nRF DKs and Dongle, if using JLink debugger host firmware, you need to disable the Mass storage device (I don’t remember, it is something to do with 64-byte USB frames).

Hence, my request to try with MBED debugger host firmware which is a different UART to USB implementation.

 

In case using custom UART to USB, like FTDI, do you wire the CTS/RTS and using hardware flow control?

 

Same for the TTL connections, correct CTS/RTS and hardware flow control is essential.

 

The rationale being, observed HCI timeout and HCI framing errors indicate corrupted UART traffic.

 

Regards,

Vinayak

 

From: devel@... <devel@...> On Behalf Of lairdjm via Lists.Zephyrproject.Org
Sent: 05 March 2020 17:34
To: Cufi, Carles <Carles.Cufi@...>; Chettimada, Vinayak Kariappa <vinayak.kariappa.chettimada@...>; mayank7117@...; devel@...
Cc: devel@...
Subject: Re: [Zephyr-devel] hci interface stopped working after few hours #ble #hci #nrf52480 #uart

 

Hi Carles,

I was assuming it was aimed at both of us, I’m not sure about what hardware they’re using. I’ll give it a try tomorrow with the hardware I have and see if it’s working with the latest branch of zephyr.

Thanks,

Jamie

Join devel@lists.zephyrproject.org to automatically receive all group messages.