Zephyr SDK 0.11.x and Python support query


Kumar Gala
 

As part of the SDK 0.11.x SDK we moved from python2.7 to python3.6 as the version of python that GDB is linked against, partially due to the deprecation of python2.7.

There have been several issues opened about this on various Linux distributions. It was suggested that Python3.8 would be a better choice since there are options on most of the major distribution versions to install a python3.8 package.

I wanted to see if this change caused any major concerns.

If you want to test out the python3.8 version, here’s a link a test SDK build:

https://builds.zephyrproject.org/zephyrproject-rtos/sdk-ng/210/zephyr-sdk-0.11.3-beta-1-pr-210-setup.run

Please let me know by end of Thur (May 14th) if you have concerns.

Thanks

- k

Join devel@lists.zephyrproject.org to automatically receive all group messages.