Re: problems building a BME680 app: zephyr_prebuilt.elf uses VFP register arguments ....


Lawrence King
 

I experienced the same ABI issue linking an existing library when moving from Zephyr v2.2.0 to Zephyr v2.3.0.

In addition to the suggestions Charles made:
CONFIG_FP_SOFTABI=y
or
CONFIG_FP_HARDABI=y
in your prj.conf.
I also had to add
CONFIG_FPU=y
to my prj.conf so that I could link an existing library to a newly compiled project. 

Join devel@lists.zephyrproject.org to automatically receive all group messages.