[LWM2M] Client example - QEMU x86


Guillaume PAQUET <guillaume.paquet@...>
 

Hello Zephyr Community,

I am Guillaume Paquet, I worked for STIMIO company and I am now working for SMILE company, specialised in Linux Open Source Embedded topics.
I tried to run LWM2M client demo on QEMU x86 target : https://github.com/zephyrproject-rtos/zephyr/tree/master/samples/net/lwm2m_client
I tried to connect to local leshan server but I don't achieve to register. i have always the following error
[00:00:37.230,000] <dbg> net_lwm2m_engine.lwm2m_engine_get: path:0/0/1, buf:0x00144373, buflen:1
[00:00:37.230,000] <dbg> net_lwm2m_engine.lwm2m_engine_get: path:0/0/10, buf:0x001443b2, buflen:2
[00:00:37.230,000] <dbg> net_lwm2m_engine.lwm2m_engine_get: path:1/0/1, buf:0x0013dea0, buflen:4
[00:00:37.230,000] <inf> net_lwm2m_rd_client: RD Client started with endpoint 'qemu_x86' with client lifetime 30
[00:00:37.230,000] <dbg> net_lwm2m_engine.lwm2m_parse_peerinfo: Parse url: coap://192.0.2.2
[00:00:37.230,000] <dbg> net_lwm2m_rd_client.sm_send_registration: registration sent [192.0.2.2]
[00:00:39.590,000] <inf> net_lwm2m_engine: Resending message: 0x0013b4a0
[00:00:44.280,000] <inf> net_lwm2m_engine: Resending message: 0x0013b4a0
[00:00:53.660,000] <inf> net_lwm2m_engine: Resending message: 0x0013b4a0
[00:01:12.420,000] <wrn> net_lwm2m_rd_client: Registration Timeout
[00:01:12.420,000] <dbg> net_lwm2m_client_app.rd_client_event: Disconnected
[00:01:12.420,000] <dbg> net_lwm2m_client_app.rd_client_event: Registration failure!

I only activated IPv4 (I also tried IPv6 and it does not work too).
Maybe I missed something in configuration.
For information, I run ./loop-socat.sh a
--
SMILE

10-12 rue Nicolas Appert
44100 NANTES

Guillaume PAQUET
Tech Manager


Twitter Facebook LinkedIn Github


eco Pour la planète, n'imprimez ce mail que si c'est nécessaire

Join devel@lists.zephyrproject.org to automatically receive all group messages.