Il 16/12/21 22:17, Nicolas Pitre ha scritto:
On Thu, 16 Dec 2021, Abramo Bagnara wrote:I think you have noted that at least another member has presented some objections.Il 13/12/21 04:37, Nicolas Pitre ha scritto:I think <sys/util.h> would be a good place.On Sun, 12 Dec 2021, Abramo Bagnara wrote:Unless we find a good place for this macro I'd be forced to leave double cast.Who in its right mind will believe that sprinkling typecasts aroundIn the specific, double casts are needed in two situations:
Which strategies the comunity have adopted in similar cases to obtain a fast convergence and to avoid bikeshedding?
You can find it as the last commit of branch MISRA_Essential_Types ofPlease make it into a fetchable branch. That'd make my reviewing easier.I'd like very much you take a look toAnd a real kicker is this change:
Here too it seems that someone prefers Boolean returning API and others 0 success/non-zero error returning API.
The 0 success/non-zero error has the benefits to be able to return an informative error code, but currently this has not been used.
The important thing is that we get a rapid convergence of opinions, then I can easily adapt the rest to it.
The only thing I'd like it was not questioned is the need to separate for clarity and readability Boolean and integers. Integers are for arithmetic, Booleans are for logic and guards.
BUGSENG srl - http://bugseng.com