Date   

Error when using './boards/x86/common/scripts/build_grub.sh x86_64' on Clear Linux

Geoffroy Van Cutsem
 

Hi folks,

I am trying to build a GRUB2 bootloader image following these steps on a Clear Linux system (version 28230). I ran into the problem below (see output at [1]). That is a problem with gcc 8.x that has since been resolved upstream (but not in the 2.02 version used by Zephyr), I cherry-picked that change and applied it (see [2]), but now I'm running into a new, different issue:
<snip>
    -e "/OUTPUT_TERMINAL_LIST_MARKER *( *\"/{s/.*( *\"\([^\"]*\)\".*/o\1: $b/;p;}" $pp; \
done) | sort -u > terminal.lst
In file included from ../include/grub/dl.h:29,
                 from loader/i386/bsd.c:26:
loader/i386/bsd.c: In function ‘grub_cmd_openbsd’:
../include/grub/misc.h:71:10: error: ‘ptr’ may be used uninitialized in this function [-Werror=maybe-uninitialized]
   return grub_memmove (dest, src, n);
          ^~~~~~~~~~~~~~~~~~~~~~~~~~~
loader/i386/bsd.c:264:9: note: ‘ptr’ was declared here
   void *ptr;
         ^~~
In file included from ../include/grub/dl.h:29,
<snip>

Has anyone seen this?

Thanks,
Geoffroy

[1] Error when running the upstream build_grub.sh script on Clear Linux:
In file included from grub-core/partmap/gpt.c:26:
./include/grub/gpt_partition.h:79:1: error: alignment 1 of ‘struct grub_gpt_partentry’ is less than 8 [-Werror=packed-not-aligned]
 } GRUB_PACKED;
 ^
cc1: all warnings being treated as errors
make[2]: *** [Makefile:6490: grub-core/partmap/libgrubkern_a-gpt.o] Error 1
make[2]: *** Waiting for unfinished jobs....
mv -f grub-core/lib/.deps-util/grub_mkrescue-reed_solomon.Tpo grub-core/lib/.deps-util/grub_mkrescue-reed_solomon.Po
mv -f grub-core/osdep/.deps-util/grub_mkrescue-random.Tpo grub-core/osdep/.deps-util/grub_mkrescue-random.Po
mv -f grub-core/osdep/.deps-util/grub_mkrescue-ofpath.Tpo grub-core/osdep/.deps-util/grub_mkrescue-ofpath.Po
In file included from grub-core/disk/ldm.c:26:
./include/grub/gpt_partition.h:79:1: error: alignment 1 of ‘struct grub_gpt_partentry’ is less than 8 [-Werror=packed-not-aligned]
 } GRUB_PACKED;
 ^
cc1: all warnings being treated as errors
make[2]: *** [Makefile:6462: grub-core/disk/libgrubkern_a-ldm.o] Error 1
make[2]: Leaving directory '/home/gvancuts/work/zephyr/boards/x86/common/scripts/grub/src'
make[1]: *** [Makefile:11295: all-recursive] Error 1
make[1]: Leaving directory '/home/gvancuts/work/zephyr/boards/x86/common/scripts/grub/src'
make: *** [Makefile:3515: all] Error 2
./boards/x86/common/scripts/build_grub.sh: line 39: ./grub-mkimage: No such file or directory
~/work/zephyr/boards/x86/common/scripts/grub ~/work/zephyr
cp: cannot stat 'src/grub_x86_64.efi': No such file or directory

[2] Fix for "packed-not-aligned" error
$ git diff
diff --git a/boards/x86/common/scripts/build_grub.sh b/boards/x86/common/scripts/build_grub.sh
index 8b628ab809..a38cd93faa 100755
--- a/boards/x86/common/scripts/build_grub.sh
+++ b/boards/x86/common/scripts/build_grub.sh
@@ -23,6 +23,7 @@ prepare() {
   pushd src
   git checkout grub-2.02
   git cherry-pick c36c2a86404f373100775305f532c09d46f3c6ce
+  git cherry-pick 563b1da6e6ae7af46cc8354cadb5dab416989f0a
   git clean -fdx
   popd
 }


Re: Zephyr SDK 0.10.0 available

Zephyr Project
 

Hi Luiz,
The Zephyr SDK can be found on the Developers page in the Downloads section here: https://www.zephyrproject.org/developers/#downloads

We'll re-work the page so its easier to find!

Best,
Thea


On Mon, Mar 11, 2019 at 11:36 AM Luiz Augusto von Dentz <luiz.dentz@...> wrote:
Hi Kumar,

It seems there is no link for it in the developers page:

https://www.zephyrproject.org/developers/

On Sun, Mar 10, 2019 at 2:00 AM Kumar Gala <kumar.gala@...> wrote:
>
> The is the first release of the Zephyr SDK that utilizes crosstool-ng to build the toolchains. We utilize crosstool-ng-1.24.0-rc2.
>
> Toolchain version:
>
>         • GCC 8.3
>         • GDB 8.2.1
>         • BINUTILS 2.32
>         • NEWLIB 3.1.0 (except on xtensa)
>
> We continue to utilize yocto to build the hosts tools:
>
>         • Qemu 3.1.0 (SHA: 32a1a94dd324d33578dca1dc96d7896a0244d768)
>         • OpenOCD 0.10.0 - snapshot from 20190226 (SHA: f21c12abecb9df244f147740166378ede7ea398e)
>         • bossa 1.9.1 (SHA: 3279031813093aa404b8561c8dd7a39dd24ebc70)
>         • dtc 1.4.7+ (SHA: 78e113e81c9d33d0f33704b187a46399d5a75419)
>
>


--
Luiz Augusto von Dentz




Re: LE pair disconnected

Isaac Chen (陳尚航) <Isaac_Chen@...>
 

Hi Carles,

 

We are using 1.13.

 

Best Regards

 

Isaac Chen

Quanta Computer Inc.

Business Unit 11 BL1

Tel  : +886-3-327-2345 Ext : 17585

 

This transmission is intended only for the use of the addressed recipient and may contain information that is privileged, confidential and exempt from disclosure under applicable law. If you are not the intended recipient, any use of this communication is strictly prohibited. If you have received this communication in error, please kindly notify the sender and delete this message immediately. 

 

From: Cufi, Carles [mailto:Carles.Cufi@...]
Sent: Monday, March 04, 2019 7:40 PM
To: Isaac Chen (
陳尚航); Tommy Lin (林志聰); Ryan Erickson; Jamie Mccrae; Chettimada, Vinayak Kariappa; zephyr-devel@...
Cc: devel@...
Subject: RE: [Zephyr-devel] LE pair disconnected

 

Hi there,

 

Which version of Zephyr are you using? 1.13 or the latest master?

 

Thanks,

 

Carles

 

From: devel@... <devel@...> On Behalf Of via Lists.Zephyrproject.Org
Sent: 04 March 2019 08:01
To: Tommy Lin (
林志聰) <Tommy.Lin@...>; Ryan Erickson <Ryan.Erickson@...>; Jamie Mccrae <Jamie.Mccrae@...>; Chettimada, Vinayak Kariappa <vinayak.kariappa.chettimada@...>; zephyr-devel@...
Cc: devel@...
Subject: Re: [Zephyr-devel] LE pair disconnected
Importance: High

 

Hi Zephyr team,

 

We can find this issue on nRF51 DK and our custom board with zephyr source code(samples/bluetooth/hci_uart). Could you give us your advice on how to solve this issue?

 

 

 

 

 

Best Regards

 

Isaac Chen

Quanta Computer Inc.

Business Unit 11 BL1

Tel  : +886-3-327-2345 Ext : 17585

 

This transmission is intended only for the use of the addressed recipient and may contain information that is privileged, confidential and exempt from disclosure under applicable law. If you are not the intended recipient, any use of this communication is strictly prohibited. If you have received this communication in error, please kindly notify the sender and delete this message immediately. 

 

From: Tommy Lin (林志聰)
Sent: Wednesday, February 27, 2019 4:03 PM
To: Ryan Erickson; Jamie Mccrae; Isaac Chen (
陳尚航); Chettimada, Vinayak Kariappa; zephyr-devel@...
Cc: Hanyu.Hsu@...; Ryan Hsu (
徐振鋒)
Subject: [Zephyr-devel] LE pair disconnected

 

Hi Ryan Erickson,

We use zephyr source code(samples/bluetooth/hci_uart) , and type following commands:

After then , we can find out device(named “2019bt”) in our phone , and we can pair it.

But “2019bt” will be disconnected after about two second at connected.

Could you give us some suggestions

Thank  You.

 


Re: LE pair disconnected

Isaac Chen (陳尚航) <Isaac_Chen@...>
 

Hi Vinayak,

 

Do you find any cue on btmon logs?

 

 

 

 

Best Regards

 

Isaac Chen

Quanta Computer Inc.

Business Unit 11 BL1

Tel  : +886-3-327-2345 Ext : 17585

 

This transmission is intended only for the use of the addressed recipient and may contain information that is privileged, confidential and exempt from disclosure under applicable law. If you are not the intended recipient, any use of this communication is strictly prohibited. If you have received this communication in error, please kindly notify the sender and delete this message immediately. 

 

From: Tommy Lin (林志聰)
Sent: Tuesday, March 05, 2019 11:29 AM
To: Chettimada, Vinayak Kariappa; Isaac Chen (
陳尚航); Ryan Erickson; Jamie Mccrae; zephyr-devel@...
Cc: Hanyu.Hsu@...; Ryan Hsu (
徐振鋒)
Subject: RE: [Zephyr-devel] LE pair disconnected

 

Hi Vinayak,

btmon logs has been put in Attachment.

 

 

Thank You.

Tommy

From: Chettimada, Vinayak Kariappa [mailto:vinayak.kariappa.chettimada@...]
Sent: Monday, March 4, 2019 3:50 PM
To: Isaac Chen (
陳尚航) <Isaac_Chen@...>; Tommy Lin (林志聰) <Tommy.Lin@...>; Ryan Erickson <Ryan.Erickson@...>; Jamie Mccrae <Jamie.Mccrae@...>; zephyr-devel@...
Cc: Hanyu.Hsu@...; Ryan Hsu (
徐振鋒) <Ryan.Hsu@...>
Subject: Re: [Zephyr-devel] LE pair disconnected

 

Hi,

 

Could you please provide the btmon HCI logs?

 

Regards,

Vinayak

 

From: "Isaac Chen (陳尚航)" <Isaac_Chen@...>
Date: Monday, 4 March 2019 at 8:01 AM
To: "Tommy Lin (
林志聰)" <Tommy.Lin@...>, Ryan Erickson <Ryan.Erickson@...>, Jamie Mccrae <Jamie.Mccrae@...>, Vinayak Chettimada <vinayak.kariappa.chettimada@...>, "zephyr-devel@..." <zephyr-devel@...>
Cc: "Hanyu.Hsu@..." <Hanyu.Hsu@...>, "Ryan Hsu (
徐振鋒)" <Ryan.Hsu@...>
Subject: RE: [Zephyr-devel] LE pair disconnected

 

Hi Zephyr team,

 

We can find this issue on nRF51 DK and our custom board with zephyr source code(samples/bluetooth/hci_uart). Could you give us your advice on how to solve this issue?

 

 

 

 

 

Best Regards

 

Isaac Chen

Quanta Computer Inc.

Business Unit 11 BL1

Tel  : +886-3-327-2345 Ext : 17585

 

This transmission is intended only for the use of the addressed recipient and may contain information that is privileged, confidential and exempt from disclosure under applicable law. If you are not the intended recipient, any use of this communication is strictly prohibited. If you have received this communication in error, please kindly notify the sender and delete this message immediately. 

 

From: Tommy Lin (林志聰)
Sent: Wednesday, February 27, 2019 4:03 PM
To: Ryan Erickson; Jamie Mccrae; Isaac Chen (
陳尚航); Chettimada, Vinayak Kariappa; zephyr-devel@...
Cc: Hanyu.Hsu@...; Ryan Hsu (
徐振鋒)
Subject: [Zephyr-devel] LE pair disconnected

 

Hi Ryan Erickson,

We use zephyr source code(samples/bluetooth/hci_uart) , and type following commands:

After then , we can find out device(named “2019bt”) in our phone , and we can pair it.

But “2019bt” will be disconnected after about two second at connected.

Could you give us some suggestions

Thank  You.

 


Re: Zephyr SDK 0.10.0 available

Luiz Augusto von Dentz
 

Hi Kumar,

It seems there is no link for it in the developers page:

https://www.zephyrproject.org/developers/

On Sun, Mar 10, 2019 at 2:00 AM Kumar Gala <kumar.gala@linaro.org> wrote:

The is the first release of the Zephyr SDK that utilizes crosstool-ng to build the toolchains. We utilize crosstool-ng-1.24.0-rc2.

Toolchain version:

• GCC 8.3
• GDB 8.2.1
• BINUTILS 2.32
• NEWLIB 3.1.0 (except on xtensa)

We continue to utilize yocto to build the hosts tools:

• Qemu 3.1.0 (SHA: 32a1a94dd324d33578dca1dc96d7896a0244d768)
• OpenOCD 0.10.0 - snapshot from 20190226 (SHA: f21c12abecb9df244f147740166378ede7ea398e)
• bossa 1.9.1 (SHA: 3279031813093aa404b8561c8dd7a39dd24ebc70)
• dtc 1.4.7+ (SHA: 78e113e81c9d33d0f33704b187a46399d5a75419)

--
Luiz Augusto von Dentz


Does sanitycheck "--subtest" work and if yes how?

Marc Herbert
 

In this example, passing either 1, --test, or 2. --subtest, or 3. both seems to make no difference; in all 3 cases the same, complete kernel.fifo.poll set gets run:

./scripts/sanitycheck -v -v \
--test tests/kernel/fifo/fifo_api/kernel.fifo.poll \
--sub-test kernel.fifo.poll.fifo_loop \
| grep 'tarting test'


In this other, "conflicting" example, --subtest overrides --test. The --test argument is ignored and as above the complete kernel.fifo.poll set gets run:

./scripts/sanitycheck -v -v \
--test tests/kernel/fifo/fifo_usage/kernel.fifo.usage \
--sub-test kernel.fifo.poll.fifo_loop \
| grep 'tarting test'


Is this intended and why? If not what is expected to happen? Either way I'll try to clarify the --help.


Change of required SDK version to 0.10.0

Kumar Gala
 

With the release of SDK 0.10.0 (https://github.com/zephyrproject-rtos/sdk-ng/releases/tag/v0.10.0) we will be changing the required SDK version to it. The PR for that change is here:

https://github.com/zephyrproject-rtos/zephyr/pull/14236

Please upgrade your SDK to 0.10.0.

- k


Zephyr SDK 0.10.0 available

Kumar Gala
 

The is the first release of the Zephyr SDK that utilizes crosstool-ng to build the toolchains. We utilize crosstool-ng-1.24.0-rc2.

Toolchain version:

• GCC 8.3
• GDB 8.2.1
• BINUTILS 2.32
• NEWLIB 3.1.0 (except on xtensa)

We continue to utilize yocto to build the hosts tools:

• Qemu 3.1.0 (SHA: 32a1a94dd324d33578dca1dc96d7896a0244d768)
• OpenOCD 0.10.0 - snapshot from 20190226 (SHA: f21c12abecb9df244f147740166378ede7ea398e)
• bossa 1.9.1 (SHA: 3279031813093aa404b8561c8dd7a39dd24ebc70)
• dtc 1.4.7+ (SHA: 78e113e81c9d33d0f33704b187a46399d5a75419)


Re: Data Length Extension #ble #nrf52 #nrf52832 #nrf52840

Carles Cufi
 

Hi Henry,

 

Take a look at the configuration used in Nordic’s throughput sample:

https://github.com/tejlmand/fw-nrfconnect-nrf/blob/master/samples/bluetooth/throughput/prj.conf

 

I think you are missing several buffer length settings to achieve full speed.

 

Regards,

 

Carles

 

From: <devel@...> on behalf of "henry.wagner via Lists.Zephyrproject.Org" <henry.wagner=lairdtech.com@...>
Reply-To: "henry.wagner@..." <henry.wagner@...>
Date: Thursday, 7 March 2019 at 21:25
To: "devel@..." <devel@...>
Cc: "devel@..." <devel@...>
Subject: [Zephyr-devel] Data Length Extension #ble #nrf52 #nrf52832 #nrf52840

 

I am trying to enable data length extensions in a connection but am limited to the std 20 payload bytes.
I have a Nordic PCA10040 (nRF52832) running Zephyr v1.14rc1 as a central connected to a Laird BL654 module.  Both devices have what I believe to be DLE enabled.
On the Zephyr side I have enabled:

CONFIG_BT_PHY_UPDATE=y

CONFIG_BT_DATA_LEN_UPDATE=y

CONFIG_BT_CTLR_DATA_LENGTH=y

CONFIG_BT_CTLR_DATA_LENGTH_MAX=251

CONFIG_BT_CTLR_PHY=y
On the BL654 side, the startup flags are set to enable 2M PHY and DLE.
Haven't found a lot of info (other than it should be enabled in the BT stack) or a working sample.  Any help/insight is appreciated.
Henry


Data Length Extension #ble #nrf52 #nrf52832 #nrf52840

henry.wagner@...
 

I am trying to enable data length extensions in a connection but am limited to the std 20 payload bytes.
I have a Nordic PCA10040 (nRF52832) running Zephyr v1.14rc1 as a central connected to a Laird BL654 module.  Both devices have what I believe to be DLE enabled.
On the Zephyr side I have enabled:
CONFIG_BT_PHY_UPDATE=y
CONFIG_BT_DATA_LEN_UPDATE=y
CONFIG_BT_CTLR_DATA_LENGTH=y
CONFIG_BT_CTLR_DATA_LENGTH_MAX=251
CONFIG_BT_CTLR_PHY=y
On the BL654 side, the startup flags are set to enable 2M PHY and DLE.
Haven't found a lot of info (other than it should be enabled in the BT stack) or a working sample.  Any help/insight is appreciated.
Henry


Re: How can I configure optimization_level for my project?

Andrei Gansari
 

Hello Kai,

 

I’ve previously used -DCONFIG_NO_OPTIMIZATIONS=y when compiling to use O0. (default zephyr_sdk, should work for gcc-arm-none-eabi)

Have a look at zephyr\cmake\compiler\gcc\target_optimizations.cmake and zephyr\CMakeLists.txt for options.

 

Andrei Gansari

 

From: devel@... <devel@...> On Behalf Of Kai Ren via Lists.Zephyrproject.Org
Sent: Thursday, March 7, 2019 7:23 AM
To: devel@...
Cc: devel@...
Subject: [Zephyr-devel] How can I configure optimization_level for my project?

 

Hello,

I'm using gcc-arm-none-eabi as the compiler, as I know, this compiler can be configured for optimization_level, like no-optimization, optimizing size or optimizing speed. 
I'm curious that how can I set it up?

Thanks. 

Kai


How can I configure optimization_level for my project?

Kai Ren
 

Hello,

I'm using gcc-arm-none-eabi as the compiler, as I know, this compiler can be configured for optimization_level, like no-optimization, optimizing size or optimizing speed. 
I'm curious that how can I set it up?

Thanks. 

Kai


BUGS (Zephyr v1.14.0-rc1) Mar 5 2019

Kumar Gala
 

193:bug

95:priority: low
93:priority: medium
4:priority: high

24:area: Networking
22:Coverity
13:area: Bluetooth
11:area: MISRA-C
11:area: Logging
10:platform: nRF
10:area: Drivers
9:platform: NXP
9:area: Tests
8:area: Xtensa
7:platform: ESP32
6:area: Samples
6:area: Memory Protection
6:area: I2C
6:area: File System
6:area: Counter
6:area: ARM
6:area: ARC
5:area: Watchdog
5:area: Sockets
5:area: Kernel
4:area: USB
4:area: Documentation
3:platform: STM32
3:area: UART
3:area: Other
3:area: NIOS2
3:area: Device Tree
3:area: Boards
2:in progress
2:good first issue
2:area: west
2:area: mcumgr
2:area: Toolchains
2:area: Testing
2:area: Shell
2:area: SPI
2:area: Power Management
2:area: Portability
2:area: PWM
2:area: GPIO
2:area: Ethernet
2:area: Display
2:area: Crypto / RNG
2:area: Conformance
2:area: CAN
1:to do
1:platform: ATMEL
1:area: Testing Suite
1:area: Security
1:area: POSIX
1:area: PCI
1:area: OpenThread
1:area: OTA
1:area: Networking Clients
1:area: LWM2M
1:area: Kconfig
1:area: IPC
1:area: Flash
1:area: Console
1:area: Configuration System
1:area: C Library
1:area: Build System
1:Trivial
1:LTS
1:EXT


RFC: Changing the `west build` command-line interface

Carles Cufi
 

Hi there,

As you know, west now allows users to build Zephyr applications with it, and many among us have started making use of this new functionality.

The signature for `west build` currently reads (and has done so from its introduction):

usage: west build [-h] [-b BOARD] [-s SOURCE_DIR] [-d BUILD_DIR] [-t TARGET]
[-c] [-f]
[cmake_opt [cmake_opt ...]]

Which means that, in order to specify the source directory (i.e. the sample that you want to build) you either invoke `west build` directly from it or you use the `-s` optional argument like so:

west build -b reel_board -s samples/hello_world

Since we anticipate `west build` to be widely used in the future, I am proposing a change whereby the source directory would be specified as the first optional argument:

west build -b reel_board samples/hello_world

to save some typing and also to be consistent with CMake, which is invoked automatically by west when required.

The new signature would look like:

usage: west build [-h] [-b BOARD] [-d BUILD_DIR]
[-t TARGET] [-c] [-f] [source_dir]
-- [cmake_opt [cmake_opt ...]]

This has a few implications worth discussing:

1. The change is not entirely backwards-compatible but we have kept the `-s` option (as a hidden one) in order to break as few existing scripts as possible
2. `west build` allows you to pass on additional arguments to CMake. Before this change, those were all and any positional arguments present in the invocation line. Now however, the first positional argument is always treated as the source directory, unless a `--` separator is present, in which case the source directory is assumed as implicit (CWD) and all arguments after `--` are treated as CMake options to be passed on to it.

Additional information can be found in the PR and its review comments:
https://github.com/zephyrproject-rtos/zephyr/pull/13635

Please add your feedback in the PR and let us know what you think of the proposed change.

Thanks,

Carles


Re: BLE Central max concurrent connections #uart #ble #hci #nrf52480

Carles Cufi
 

Hi Josef,

 

There is no maximum, neither as a central nor as a peripheral, nor combined.

Whatever you can fit in RAM and in multiplexed time (depending on connection intervals, use of slave latency, etc).

 

Carles

 

From: devel@... <devel@...> On Behalf Of josef via Lists.Zephyrproject.Org
Sent: 05 March 2019 10:05
To: devel@...
Cc: devel@...
Subject: [Zephyr-devel] BLE Central max concurrent connections #ble #hci #nrf52480 #uart

 

Hi,

I am evaluating the use of nRF52 (HCI with BlueZ/Linux) as BLE central device. Does anyone know the maximum number of concurrent connections which Zephyr supports?

Many thanks,
Jos


BLE Central max concurrent connections #uart #ble #hci #nrf52480

josef@...
 

Hi,

I am evaluating the use of nRF52 (HCI with BlueZ/Linux) as BLE central device. Does anyone know the maximum number of concurrent connections which Zephyr supports?

Many thanks,
Jos


Re: LE pair disconnected

Tommy Lin (林志聰) <Tommy.Lin@...>
 

Hi Vinayak,

btmon logs has been put in Attachment.

 

 

Thank You.

Tommy

From: Chettimada, Vinayak Kariappa [mailto:vinayak.kariappa.chettimada@...]
Sent: Monday, March 4, 2019 3:50 PM
To: Isaac Chen (
陳尚航) <Isaac_Chen@...>; Tommy Lin (林志聰) <Tommy.Lin@...>; Ryan Erickson <Ryan.Erickson@...>; Jamie Mccrae <Jamie.Mccrae@...>; zephyr-devel@...
Cc: Hanyu.Hsu@...; Ryan Hsu (
徐振鋒) <Ryan.Hsu@...>
Subject: Re: [Zephyr-devel] LE pair disconnected

 

Hi,

 

Could you please provide the btmon HCI logs?

 

Regards,

Vinayak

 

From: "Isaac Chen (陳尚航)" <Isaac_Chen@...>
Date: Monday, 4 March 2019 at 8:01 AM
To: "Tommy Lin (
林志聰)" <Tommy.Lin@...>, Ryan Erickson <Ryan.Erickson@...>, Jamie Mccrae <Jamie.Mccrae@...>, Vinayak Chettimada <vinayak.kariappa.chettimada@...>, "zephyr-devel@..." <zephyr-devel@...>
Cc: "Hanyu.Hsu@..." <Hanyu.Hsu@...>, "Ryan Hsu (
徐振鋒)" <Ryan.Hsu@...>
Subject: RE: [Zephyr-devel] LE pair disconnected

 

Hi Zephyr team,

 

We can find this issue on nRF51 DK and our custom board with zephyr source code(samples/bluetooth/hci_uart). Could you give us your advice on how to solve this issue?

 

 

 

 

 

Best Regards

 

Isaac Chen

Quanta Computer Inc.

Business Unit 11 BL1

Tel  : +886-3-327-2345 Ext : 17585

 

This transmission is intended only for the use of the addressed recipient and may contain information that is privileged, confidential and exempt from disclosure under applicable law. If you are not the intended recipient, any use of this communication is strictly prohibited. If you have received this communication in error, please kindly notify the sender and delete this message immediately. 

 

From: Tommy Lin (林志聰)
Sent: Wednesday, February 27, 2019 4:03 PM
To: Ryan Erickson; Jamie Mccrae; Isaac Chen (
陳尚航); Chettimada, Vinayak Kariappa; zephyr-devel@...
Cc: Hanyu.Hsu@...; Ryan Hsu (
徐振鋒)
Subject: [Zephyr-devel] LE pair disconnected

 

Hi Ryan Erickson,

We use zephyr source code(samples/bluetooth/hci_uart) , and type following commands:

After then , we can find out device(named “2019bt”) in our phone , and we can pair it.

But “2019bt” will be disconnected after about two second at connected.

Could you give us some suggestions

Thank  You.

 


Re: LE pair disconnected

Tommy Lin (林志聰) <Tommy.Lin@...>
 

Hi Vinayak,

btmon logs has been put in Attachment.

 

 

Thank You.

Tommy

From: Chettimada, Vinayak Kariappa [mailto:vinayak.kariappa.chettimada@...]
Sent: Monday, March 4, 2019 3:50 PM
To: Isaac Chen (
陳尚航) <Isaac_Chen@...>; Tommy Lin (林志聰) <Tommy.Lin@...>; Ryan Erickson <Ryan.Erickson@...>; Jamie Mccrae <Jamie.Mccrae@...>; zephyr-devel@...
Cc: Hanyu.Hsu@...; Ryan Hsu (
徐振鋒) <Ryan.Hsu@...>
Subject: Re: [Zephyr-devel] LE pair disconnected

 

Hi,

 

Could you please provide the btmon HCI logs?

 

Regards,

Vinayak

 

From: "Isaac Chen (陳尚航)" <Isaac_Chen@...>
Date: Monday, 4 March 2019 at 8:01 AM
To: "Tommy Lin (
林志聰)" <Tommy.Lin@...>, Ryan Erickson <Ryan.Erickson@...>, Jamie Mccrae <Jamie.Mccrae@...>, Vinayak Chettimada <vinayak.kariappa.chettimada@...>, "zephyr-devel@..." <zephyr-devel@...>
Cc: "Hanyu.Hsu@..." <Hanyu.Hsu@...>, "Ryan Hsu (
徐振鋒)" <Ryan.Hsu@...>
Subject: RE: [Zephyr-devel] LE pair disconnected

 

Hi Zephyr team,

 

We can find this issue on nRF51 DK and our custom board with zephyr source code(samples/bluetooth/hci_uart). Could you give us your advice on how to solve this issue?

 

 

 

 

 

Best Regards

 

Isaac Chen

Quanta Computer Inc.

Business Unit 11 BL1

Tel  : +886-3-327-2345 Ext : 17585

 

This transmission is intended only for the use of the addressed recipient and may contain information that is privileged, confidential and exempt from disclosure under applicable law. If you are not the intended recipient, any use of this communication is strictly prohibited. If you have received this communication in error, please kindly notify the sender and delete this message immediately. 

 

From: Tommy Lin (林志聰)
Sent: Wednesday, February 27, 2019 4:03 PM
To: Ryan Erickson; Jamie Mccrae; Isaac Chen (
陳尚航); Chettimada, Vinayak Kariappa; zephyr-devel@...
Cc: Hanyu.Hsu@...; Ryan Hsu (
徐振鋒)
Subject: [Zephyr-devel] LE pair disconnected

 

Hi Ryan Erickson,

We use zephyr source code(samples/bluetooth/hci_uart) , and type following commands:

After then , we can find out device(named “2019bt”) in our phone , and we can pair it.

But “2019bt” will be disconnected after about two second at connected.

Could you give us some suggestions

Thank  You.

 


Re: Seeing and running what CI does (was: CODEOWNERS check in CI)

Marc Herbert
 

On 3 Mar 2019, at 09:09, Nashif, Anas <anas.nashif@intel.com> wrote:

2. As the opposite experience, I also got for another work in progress / hack / draft PR:
Documentation build with 'make htmldocs' failed.
... and that's it; no logs or error message whatsoever, just this line. I have some guesses of what fails in CI while everything works for me (it is a documentation _hack_) but zero information on what exactly or how.
2. & 3. https://github.com/zephyrproject-rtos/zephyr/pull/13805

Still unclear.

A python exception happens in this case, you can always reproduce it locally by running 'make htmldocs'.

As I wrote above "make htmldocs" works for me, this PR is actually
an htmldocs demo.


I am not sure how useful would it be putting the python exception...


It would point at the difference(s) between my environment and
CI = the vast majority of CI failures when testing locally and
thoroughly first.

Again I do have a couple of educated guesses about these differences
(help NOT desired here yet) but they're just that: guesses. No proof.

... in the comments.

Not in the comments but behind some kind of "Details" button with all
the rest of the logs and commands that produced them; exactly like
Shippable (and only Shippable now) does.

Having some smart "error analyzer" summarizing in the github comments
how it understood the unexpected failure would be cool. However it's not
mutually exclusive with sharing complete logs and commands as most
successful CIs do.


Re: LE pair disconnected

Carles Cufi
 

Hi there,

 

Which version of Zephyr are you using? 1.13 or the latest master?

 

Thanks,

 

Carles

 

From: devel@... <devel@...> On Behalf Of via Lists.Zephyrproject.Org
Sent: 04 March 2019 08:01
To: Tommy Lin (
林志聰) <Tommy.Lin@...>; Ryan Erickson <Ryan.Erickson@...>; Jamie Mccrae <Jamie.Mccrae@...>; Chettimada, Vinayak Kariappa <vinayak.kariappa.chettimada@...>; zephyr-devel@...
Cc: devel@...
Subject: Re: [Zephyr-devel] LE pair disconnected
Importance: High

 

Hi Zephyr team,

 

We can find this issue on nRF51 DK and our custom board with zephyr source code(samples/bluetooth/hci_uart). Could you give us your advice on how to solve this issue?

 

 

 

 

 

Best Regards

 

Isaac Chen

Quanta Computer Inc.

Business Unit 11 BL1

Tel  : +886-3-327-2345 Ext : 17585

 

This transmission is intended only for the use of the addressed recipient and may contain information that is privileged, confidential and exempt from disclosure under applicable law. If you are not the intended recipient, any use of this communication is strictly prohibited. If you have received this communication in error, please kindly notify the sender and delete this message immediately. 

 

From: Tommy Lin (林志聰)
Sent: Wednesday, February 27, 2019 4:03 PM
To: Ryan Erickson; Jamie Mccrae; Isaac Chen (
陳尚航); Chettimada, Vinayak Kariappa; zephyr-devel@...
Cc: Hanyu.Hsu@...; Ryan Hsu (
徐振鋒)
Subject: [Zephyr-devel] LE pair disconnected

 

Hi Ryan Erickson,

We use zephyr source code(samples/bluetooth/hci_uart) , and type following commands:

After then , we can find out device(named “2019bt”) in our phone , and we can pair it.

But “2019bt” will be disconnected after about two second at connected.

Could you give us some suggestions

Thank  You.

 

2441 - 2460 of 8204