Problems with MQTT on FRDM-K64F


Kevin Stöckl <k_stoeckl@...>
 

Hello,

I try to run the sample mqtt publisher on the frdm-k64f.

First I changed the IP-adress on the linux host machine to 192.168.0.75.

Then i type make BOARD=frdm_k64f and then I try to run mosquitto with sudo mosquitto -v -p 1883.

There I got the error message Address already in use and nothing happens.


In the config.h File I changed the Server Address to 192.168.0.75


What could be the problem?

How can I change the IP-adress of the board? And is this necessary?



Thanks in advance

Kevin


aska.wu
 

For the problem of address already in use, it seems that mosquitto is already running,
If you see there's a mosquitto process in "ps aux |grep mosquit", try to stop the existing one by "sudo service mosquitto stop".

Aska Wu


On Tue, 27 Jun 2017 at 21:05 Kevin Stöckl <k_stoeckl@...> wrote:

Hello,

I try to run the sample mqtt publisher on the frdm-k64f.

First I changed the IP-adress on the linux host machine to 192.168.0.75.

Then i type make BOARD=frdm_k64f and then I try to run mosquitto with sudo mosquitto -v -p 1883.

There I got the error message Address already in use and nothing happens.


In the config.h File I changed the Server Address to 192.168.0.75


What could be the problem?

How can I change the IP-adress of the board? And is this necessary?



Thanks in advance

Kevin

_______________________________________________
Zephyr-devel mailing list
Zephyr-devel@...
https://lists.zephyrproject.org/mailman/listinfo/zephyr-devel


Kevin Stöckl <k_stoeckl@...>
 

Thank you that works. But there is also the problem with the ip-adresses. I had an Ethernet connection on my Linux host machine and on the board. 

Then I changed the ip-address of the host machine to a static ip-address and in the config.h File I changed the Server Address to that static ip-address.


Is this right?

But how can I change the ip-address of the Board?


The output from "sudo mosquitto -v -p 1883" is:

1498639665: Using default config.
1498639665: Opening ipv4 listen socket on port 1883.
1498639665: Opening ipv6 listen socket on port 1883.
1498639670: New connection from 127.0.0.1 on port 1883.
1498639670: New client connected from 127.0.0.1 as mosqsub/10141-kevin-R51 (c1, k60).
1498639670: Sending CONNACK to mosqsub/10141-kevin-R51 (0, 0)
1498639670: Received SUBSCRIBE from mosqsub/10141-kevin-R51
1498639670: sensors (QoS 0)
1498639670: mosqsub/10141-kevin-R51 0 sensors
1498639670: Sending SUBACK to mosqsub/10141-kevin-R51
1498639730: Received PINGREQ from mosqsub/10141-kevin-R51

The output from minicom of the Board is:
[dev/eth_mcux] [DBG] eth_0_init: MAC 00:04:9f:62:d1:ca
net_context_connect error
Is the server (broker) up and running?
[publisher:248] network_setup: -60 <ERROR>

Bye!
[dev/eth_mcux] [INF] eth_mcux_phy_event: Enabled 100M full-duplex mode.

From mosquitto_sub -t sensors there is no output







Von: Aska Wu <aska.wu@...>
Gesendet: Mittwoch, 28. Juni 2017 04:27
An: Kevin Stöckl; zephyr-devel@...
Betreff: Re: [Zephyr-devel] Problems with MQTT on FRDM-K64F
 
For the problem of address already in use, it seems that mosquitto is already running,
If you see there's a mosquitto process in "ps aux |grep mosquit", try to stop the existing one by "sudo service mosquitto stop".

Aska Wu


On Tue, 27 Jun 2017 at 21:05 Kevin Stöckl <k_stoeckl@...> wrote:

Hello,

I try to run the sample mqtt publisher on the frdm-k64f.

First I changed the IP-adress on the linux host machine to 192.168.0.75.

Then i type make BOARD=frdm_k64f and then I try to run mosquitto with sudo mosquitto -v -p 1883.

There I got the error message Address already in use and nothing happens.


In the config.h File I changed the Server Address to 192.168.0.75


What could be the problem?

How can I change the IP-adress of the board? And is this necessary?



Thanks in advance

Kevin

_______________________________________________
Zephyr-devel mailing list
Zephyr-devel@...
https://lists.zephyrproject.org/mailman/listinfo/zephyr-devel