Topics

boards: Add Pico-Pi i.MX7D


Joris Offouga
 

Hello,

I am new zephyr user and I try to integrate the Pico-Pi i.MX7D board, during my compilations, I have this warning :

warning: 'imx_gpio_driver_api' defined but not used [-Wunused-const-variable=]
 static const struct gpio_driver_api imx_gpio_driver_api = {
                                     ^~~~~~~~~~~~~~~~~~~
/home/jun/zephyr/drivers/gpio/gpio_imx.c:157:13: warning: 'imx_gpio_port_isr' defined but not used [-Wunused-function]
 static void imx_gpio_port_isr(void *arg)

But I do not use gpio in the example, I build correctly the hello_world example, the binary works well on the target but I will like the corrected for this PR : https://github.com/zephyrproject-rtos/zephyr/pull/11913

Best regards

Joris





--
Best Regards,

Joris Offouga


Diego Sueiro
 

On Fri, 7 Dec 2018 at 08:48, jun <offougajoris@...> wrote:

Hello,

I am new zephyr user and I try to integrate the Pico-Pi i.MX7D board,
during my compilations, I have this warning :

warning: 'imx_gpio_driver_api' defined but not used
[-Wunused-const-variable=]
static const struct gpio_driver_api imx_gpio_driver_api = {
^~~~~~~~~~~~~~~~~~~
/home/jun/zephyr/drivers/gpio/gpio_imx.c:157:13: warning:
'imx_gpio_port_isr' defined but not used [-Wunused-function]
static void imx_gpio_port_isr(void *arg)

But I do not use gpio in the example, I build correctly the hello_world
example, the binary works well on the target but I will like the
corrected for this PR :
https://github.com/zephyrproject-rtos/zephyr/pull/11913
In the "soc/arm/nxp_imx/mcimx7_m4/Kconfig.defconfig.mcimx7_m4" we
default the GPIO config to "y" which will make the GPIO_IMX config
default to "y" as well.

I think you can have "CONFIG_GPIO=n" in the
boards/arm/pico_pi_m4/pico_pi_m4_defconfig file to get rid of this
warning.