Topics

Minimum required CMake version is now 3.13.1


Nashif, Anas
 

s/not/now/ in the title J

 

From: devel@... [mailto:devel@...] On Behalf Of Nashif, Anas
Sent: Thursday, January 3, 2019 11:52 AM
To: devel@...
Subject: [Zephyr-devel] Minimum required CMake version is not 3.13.1

 

Hi,

 

We have changed the minimal requirement version of cmake to 3.13.1 meaning that you are required to update cmake on your system to build Zephyr.

 

Please follow the documentation below to satisfy the requirements:

 

https://docs.zephyrproject.org/latest/getting_started/installation_linux.html#install-requirements-and-dependencies

 

The reasons for a recent version of CMake is explain here:

 

https://github.com/zephyrproject-rtos/zephyr/pull/12022#issuecomment-446589193

 

We have a few requests to include CMake in the SDK, this is something we are considering in the new SDK based on crosstools-ng.

 

Regards,

Anas

 


Andy Ross
 

Uh... those instructions still tell you to get cmake 3.8.2 :)

The latest is currently at https://cmake.org/files/LatestRelease/cmake-3.13.2-Linux-x86_64.sh it seems.

Andy


From: Nashif, Anas <anas.nashif@...>
Sent: Thursday, January 03, 2019 9:12AM
To: Nashif, Anas, Devel
Subject: Re: [Zephyr-devel] Minimum required CMake version is now 3.13.1

s/not/now/ in the title J

 

From: devel@... [mailto:devel@...] On Behalf Of Nashif, Anas
Sent: Thursday, January 3, 2019 11:52 AM
To: devel@...
Subject: [Zephyr-devel] Minimum required CMake version is not 3.13.1

 

Hi,

 

We have changed the minimal requirement version of cmake to 3.13.1 meaning that you are required to update cmake on your system to build Zephyr.

 

Please follow the documentation below to satisfy the requirements:

 

https://docs.zephyrproject.org/latest/getting_started/installation_linux.html#install-requirements-and-dependencies

 

The reasons for a recent version of CMake is explain here:

 

https://github.com/zephyrproject-rtos/zephyr/pull/12022#issuecomment-446589193

 

We have a few requests to include CMake in the SDK, this is something we are considering in the new SDK based on crosstools-ng.

 

Regards,

Anas

 



Nashif, Anas
 

Yeah, forgot that the docs get updated only once a day L

 

Documentation is now being updated and will be available in the new version shortly.

 

Anas

 

 

From: devel@... [mailto:devel@...] On Behalf Of Andy Ross
Sent: Thursday, January 3, 2019 12:31 PM
To: Nashif, Anas <anas.nashif@...>; devel@...
Subject: Re: [Zephyr-devel] Minimum required CMake version is now 3.13.1

 

Uh... those instructions still tell you to get cmake 3.8.2 :)

The latest is currently at https://cmake.org/files/LatestRelease/cmake-3.13.2-Linux-x86_64.sh it seems.

Andy

From: Nashif, Anas <anas.nashif@...>
Sent: Thursday, January 03, 2019 9:12AM
To: Nashif, Anas, Devel
Subject: Re: [Zephyr-devel] Minimum required CMake version is now 3.13.1

s/not/now/ in the title J

 

From: devel@... [mailto:devel@...] On Behalf Of Nashif, Anas
Sent: Thursday, January 3, 2019 11:52 AM
To: devel@...
Subject: [Zephyr-devel] Minimum required CMake version is not 3.13.1

 

Hi,

 

We have changed the minimal requirement version of cmake to 3.13.1 meaning that you are required to update cmake on your system to build Zephyr.

 

Please follow the documentation below to satisfy the requirements:

 

https://docs.zephyrproject.org/latest/getting_started/installation_linux.html#install-requirements-and-dependencies

 

The reasons for a recent version of CMake is explain here:

 

https://github.com/zephyrproject-rtos/zephyr/pull/12022#issuecomment-446589193

 

We have a few requests to include CMake in the SDK, this is something we are considering in the new SDK based on crosstools-ng.

 

Regards,

Anas