Topics

app runs using 1.13 but does not using 1.14


Abderrezak Mekkaoui <ab.mekka@...>
 

Hi All,

I have an app, based on the Bluetooth peripheral_esp sample, that builds and runs as expected using zephyr 1.13.99. Using 1.14, it builds correctly but crashes with the following message:

***** MPU FAULT *****
  Instruction Access Violation
***** Hardware exception *****
Current thread ID = 0x200022d0
Faulting instruction address = 0x200049a0
Fatal fault in essential thread! Spinning..

Before crashing it displays some expected sensor readings. It looks like Bluetooth fails completely.
Any quick hints on what might be the cause?
Thanks

Abderrezak


Jiří Kubias
 

Hi,
you can get the error line by issuing command
/opt/zephyr-sdk/arm-zephyr-eabi/bin/arm-zephyr-eabi-addr2line -e zephyr/zephyr.elf 0x200049a0  - this will show you where the error is. 

Best regard, 
Jiri 

pá 26. 4. 2019 v 15:33 odesílatel Abderrezak Mekkaoui <ab.mekka@...> napsal:

Hi All,

I have an app, based on the Bluetooth peripheral_esp sample, that builds
and runs as expected using zephyr 1.13.99. Using 1.14, it builds
correctly but crashes with the following message:

***** MPU FAULT *****
   Instruction Access Violation
***** Hardware exception *****
Current thread ID = 0x200022d0
Faulting instruction address = 0x200049a0
Fatal fault in essential thread! Spinning..

Before crashing it displays some expected sensor readings. It looks like
Bluetooth fails completely.
Any quick hints on what might be the cause?
Thanks

Abderrezak






--
===================================================
Ing. Jiri Kubias
 
e-mail: jiri.kubias@...
mobile: 775 593 956
===================================================