Announcing: mcuboot release 1.4.0-rc1
Forwarding, as this is of interest to some Zephyr developers.
----- Forwarded message from David Brown <@d3zd3z> -----
Date: Tue, 8 Oct 2019 11:54:31 -0600
From: David Brown <@d3zd3z>
Subject: Announcing: mcuboot release 1.4.0-rc1
I would like to announce the first release candidate for MCUboot
## Version 1.4.0
The 1.4.0 release of MCUboot primarily adds support for multi-image
booting. With this release, MCUboot can manage two images that can be
updated independently. With this, it also supports additions to the
TLV that allow these dependencies to be specified.
Multi-image support adds backward-incompatible changes to the format
of the images: specifically adding support for protected TLV entries.
If multiple images and dependencies are not used, the images will be
compatible with previous releases of MCUboot.
### About this release
- Fixed CVE-2019-5477. This fixes an issue with a dependency used in
the generation of the documentation on github.
- Numerous code cleanups and refactorings
- Documentation updates for multi-image features
- Update imgtool.py to support the new features
2 Andrzej Puzdrowski
1 Ben McCrea
1 Christian Skubich
24 David Brown
5 David Vincze
57 Fabio Utzig
3 Håkon Øye Amundsen
1 Marek Pieta
4 Marti Bolivar
1 Tamas Ban
----- End forwarded message -----
"David Brown via Lists.Zephyrproject.Org"
Forwarding, as this is of interest to some Zephyr developers.Replying with dev-mcuboot in CC. Thanks for this forward; I forgot to
join that list when I switched jobs.
It looks like this affects the image header, by replacing a padding
field in struct image_header with a new ih_protect_tlv_size field.
However, the ih_magic field value (0x96f3b83d) is still the same. If
this is meant to be incompatible, shouldn't that require a bump of the
magic number and therefore the MCUboot major version?
"Bolivar, Marti via Lists.Zephyrproject.Org"
"David Brown via Lists.Zephyrproject.Org"... and again with that list in To:
We really need the zephyr list to stop munging the headers!
Thanks for this forward; I forgot to join that list when I switched