Can't init device hci0: Cannot assign requested address (99) #nrf52


lairdjm
 

Hi Akshay,

00:00:00:00:00:00 is not a valid Bluetooth address, set a valid Bluetooth address and try again

Thanks,

Jamie

 

From: devel@... <devel@...> On Behalf Of akshaykulkarniak via lists.zephyrproject.org
Sent: 23 June 2021 10:45
To: devel@...
Subject: [Zephyr-devel] Can't init device hci0: Cannot assign requested address (99) #nrf52 #nrf52 #nrf52

 

Hi there ,

I am trying to bring up a BT (HCI interface) module connected to a qualcomm chipset

Trying to bring up the interface using hciconfig but it fails with error no.99 .

 

Note : ttyUSB here is a cp210x (USB-UART bridge) connected via HSIC

 

Below are the logs

 

root@swi-mdm9x28-wp:~# hciattach -s 115200 /dev/ttyUSB2 any 115200 noflow nosleep

Device setup complete

 

root@swi-mdm9x28-wp:~# hciconfig -a

hci0: Type: Primary Bus: UART

BD Address: 00:00:00:00:00:00 ACL MTU: 27:7 SCO MTU: 0:0

DOWN 

RX bytes:205 acl:0 sco:0 events:14 errors:0

TX bytes:80 acl:0 sco:0 commands:14 errors:0

Features: 0x00 0x00 0x00 0x00 0x60 0x00 0x00 0x00

 Packet type: DM1 DH1 HV1 

 Link policy: 

Link mode: MASTER

 

root@swi-mdm9x28-wp:~# hciconfig hci0 up

Can’t init device hci0: Cannot assign requested address (99)

root@swi-mdm9x28-wp:~# hciconfig hci0 up

Can’t init device hci0: Cannot assign requested address (99)

root@swi-mdm9x28-wp:~# hciconfig hci0 up

Can’t init device hci0: Cannot assign requested address (99)

root@swi-mdm9x28-wp:~# hciconfig hci0 up

Can’t init device hci0: Cannot assign requested address (99)

root@swi-mdm9x28-wp:~# hciconfig hci0 up

Can’t init device hci0: Cannot assign requested address (99)

 

Below are the Details of the Chipset 

 

Module : Sierra Wireless WP7608 (Chipset : QC MDM9x28)

Linux Kernel version  : 3.18.140

Yocto Project : 2.5

 

Please Let me know a possible solution to overcome this .

 

Thanks & Regards

- Akshay

 


akshaykulkarniak@...
 

Hi there ,
I am trying to bring up a BT (HCI interface) module connected to a qualcomm chipset
Trying to bring up the interface using hciconfig but it fails with error no.99 .
 
Note : ttyUSB here is a cp210x (USB-UART bridge) connected via HSIC
 
Below are the logs
 
root@swi-mdm9x28-wp:~# hciattach -s 115200 /dev/ttyUSB2 any 115200 noflow nosleep
Device setup complete
 
root@swi-mdm9x28-wp:~# hciconfig -a
hci0: Type: Primary Bus: UART
BD Address: 00:00:00:00:00:00 ACL MTU: 27:7 SCO MTU: 0:0
DOWN 
RX bytes:205 acl:0 sco:0 events:14 errors:0
TX bytes:80 acl:0 sco:0 commands:14 errors:0
Features: 0x00 0x00 0x00 0x00 0x60 0x00 0x00 0x00
 Packet type: DM1 DH1 HV1 
 Link policy: 
Link mode: MASTER
 
root@swi-mdm9x28-wp:~# hciconfig hci0 up
Can’t init device hci0: Cannot assign requested address (99)
root@swi-mdm9x28-wp:~# hciconfig hci0 up
Can’t init device hci0: Cannot assign requested address (99)
root@swi-mdm9x28-wp:~# hciconfig hci0 up
Can’t init device hci0: Cannot assign requested address (99)
root@swi-mdm9x28-wp:~# hciconfig hci0 up
Can’t init device hci0: Cannot assign requested address (99)
root@swi-mdm9x28-wp:~# hciconfig hci0 up
Can’t init device hci0: Cannot assign requested address (99)
 
Below are the Details of the Chipset 
 
Module : Sierra Wireless WP7608 (Chipset : QC MDM9x28)
Linux Kernel version  : 3.18.140
Yocto Project : 2.5
 
Please Let me know a possible solution to overcome this .
 
Thanks & Regards
- Akshay