Log subsystem stopped working when execute the shell command


Srinivasan Tamilarasan
 

Hi Krzysztof,

Thank you for your suggestion. I have cherry-picked this particular commit(https://github.com/zephyrproject-rtos/zephyr/pull/41969) to my application and tested it.

 

Now the logs continuously prints even shell commands received.

 

The issue got resolved now.

 

Thanks & Regards,

Srinivasan

 

From: devel@... <devel@...> On Behalf Of Chruscinski, Krzysztof via lists.zephyrproject.org
Sent: 07 February 2022 07:30 PM
To: devel@...; Srinivasan Tamilarasan <Srinivasan.Tamilarasan@...>
Subject: [Zephyr-devel] ODP: Log subsystem stopped working when execute the shell command

 

[External Email]: This email arrived from an external source - Please exercise caution when opening any attachments or clicking on links.

Hi,

 

it sounds like issues seen in logging and fixed on master by:

Algorithm was failing in case when overflow mode was enabled but allocation of new message failed. It could happen if message size exceeded buffer size. Losing track of buffered messages can lead t...

github.com

 

It's been now backported to 2.7 branch https://github.com/zephyrproject-rtos/zephyr/pull/42541 you can try to cherry-pick or swtich to 2.7.

 

regards,

Krzysztof

Backporting #40735 and #41969 (added later as first fix was not complete).

github.com

 


Od: devel@... <devel@...> w imieniu użytkownika Srinivasan Tamilarasan via lists.zephyrproject.org <srinivasan.tamilarasan=onsemi.com@...>
Wysłane: poniedziałek, 7 lutego 2022 14:30
Do: devel@... <devel@...>
Temat: [Zephyr-devel] Log subsystem stopped working when execute the shell command

 

Hi Team,

I am using the zephyr 2.6 log v2 with deferred mode.

 

My application continuously prints the log messages on the UART console. At the same time when I try to send the shell command then the log messages stopped printing on the console, but other subsystems and applications is working fine.

 

Only logging stopped working and never come back to life.

 

Kindly assist me to resolve this issue.

 

Regards,

Srinivasan