Re: MPU FAULT when starting BLE peripheral sample on nrf52840_pca10056


Phil Hipp
 

Hey Vinayak,

how do I get these information? I’m using cmake with ninja as generator as recommended on the zephyr project page.

Mit freundlichen Grüßen / best regards,

Philipp Finke
Development Engineer
Contract Development 
lesswire GmbH | PRETTL Electronics GmbH 
 
lesswire GmbH 
Emmy-Noether-Strasse 2 
D-79110 Freiburg, Germany 
 
Phone +49 (0) 761 708 399-22 
E-Mail: finke@...








   www.lesswire.com              www.prettl-electronics.com
 
Sitz der GmbH: Rudower Chausse 30, D-12489 Berlin, Germany
Registergericht: Amtsgericht Berlin-Charlottenburg, HRB 164706 B
Geschäftsführer: Germar Rocco Mertsching, Christian Federspiel
EU-USt.ID: DE200593545

Am 03.08.2018 um 11:15 schrieb Chettimada, Vinayak Kariappa <vinayak.kariappa.chettimada@...>:

Hi Phil,
 
Could you please build with verbose and check if correct gcc library for armv7e-m is compiled in (from the correct gcc revision).
 
Which version of GCC do you use?
 
 
Regards,
Vinayak
 
 
From: users@... [mailto:users@...] On Behalf Of Phil Hipp
Sent: Friday, August 03, 2018 11:05 AM
To: users@...
Subject: [Zephyr-users] MPU FAULT when starting BLE peripheral sample on nrf52840_pca10056
 

Hello,

I'm trying to run the BLE peripheral sample of the zephyr v1.12.0 branch on the NRF52840 PCA10056 DK. I built the sample under macOS 10.13.6 using the arm-zephyr-eabi toolchain built with sdk-ng on that machine.

Every time I start the board, I get following output on the console.

***** Booting Zephyr OS v1.12.0 *****

[bt] [INF] hci_vs_init: HW Platform: Nordic Semiconductor (0x0002)

[bt] [INF] hci_vs_init: HW Variant: nRF52x (0x0002)

[bt] [INF] hci_vs_init: Firmware: Standard Bluetooth controller (0x00) Version 1.12 Build 0

[bt] [WRN] bt_pub_key_gen: ECC HCI commands not available

Bluetooth initialized

[bt] [INF] bt_dev_show_info: Identity: e1:d5:6c:a1:a2:b3 (random)

[bt] [INF] bt_dev_show_info: HCI: version 5.0 (0x09) revision 0x0000, manufacturer 0x05f1

[bt] [INF] bt_dev_show_info: LMP: version 5.0 (0x09) subver 0xffff

***** MPU FAULT *****

  Executing thread ID (thread): 0x200003dc

  Faulting instruction address:  0x20000bd2

  Instruction Access Violation

Fatal fault in thread 0x200003dc! Aborting.

 

Advertising successfully started

It doesn't seem that Advertising has been started as promoted. I get the same or a similar issue with the other BLE samples, too.

Hope somebody may help me with this issue.


Join users@lists.zephyrproject.org to automatically receive all group messages.