Re: [Zephyr-devel] MPU fault while testing Bluetooth Mesh Sample demos


vikrant8051 <vikrant8051@...>
 

Hi Vinayak,

No. The issue has solved now.

Regards,
vikrant


On Thu, Sep 27, 2018 at 1:14 PM Chettimada, Vinayak Kariappa <vinayak.kariappa.chettimada@...> wrote:
Are you still receiving MPU Fault? I have solved someone's similar problem., and had a question if you are using GATT API and by any chance the control flows through bt_att_req_send function?

-Vinayak



-----Original Message-----
From: <devel@...> on behalf of Jiří Kubias <jiri.kubias@...>
Date: Tuesday, 18 September 2018 at 8:07 AM
To: vikrant8051 <vikrant8051@...>
Cc: Carles Cufi <Carles.Cufi@...>, "devel@..." <devel@...>, "users@..." <users@...>
Subject: Re: [Zephyr-devel] MPU fault while testing Bluetooth Mesh Sample demos

    Hi,
    last night I have discovered that I have messed up variables and I have tried to assign value to constant variable -> that is the reason why I have received the MPU fault.


    Best regards,
    Jiri


    po 17. 9. 2018 v 16:29 odesílatel Jiří Kubias <jiri.kubias@...> napsal:


    Hi,
    In my case the MPU falut was stable. But in your case it looks like some race condition issue.


    Try to reorganise the initialisation or add some delays.


    Regards Jiri




    Dne po 17. 9. 2018 15:39 uživatel Vikrant More <vikrant8051@...> napsal:


    Hi Jiri,
    After replying to your email, I once again started testing thoroughly.
    And yes, once again I got MPU fault.


    Regards,
    Vikrant



    On Mon, Sep 17, 2018 at 6:30 PM vikrant8051 <vikrant8051@...> wrote:


    HI Jiri,
    After latest sync with master, I've not faced MPU FAULT issue
    while testing. But it could be there. With v1.13, it could be suddenly
    pops-up without any reason (as a app developer)



    Thanks for linking your issue with this mailing list. Hope Zephyr

    core developers will resolve it.



    Regards,
    vikrant







    On Mon, Sep 17, 2018 at 12:37 PM Jiří Kubias <jiri.kubias@...> wrote:


    Hi,
    have you found a solution? Few days ago I have reported similar problem with MPU fault but with Atmel (Microchip) SAME70 chip. It is cased by binding DMA.

        dev_cfg->dev_dma = device_get_binding(CONFIG_SPI_SAM_DMA_NAME);
    if (!dev_cfg->dev_dma) {
    SYS_LOG_ERR("%s device not found", CONFIG_SPI_SAM_DMA_NAME);
    return -ENODEV;
    }





    and the console output  is

    ***** MPU FAULT *****
     Data Access Violation
     MMFAR Address: 0x412198
    ***** Hardware exception *****
    Current thread ID = 0x204024b4
    Faulting instruction address = 0x40e376
    Fatal fault in essential thread! Spinning...





    So far I didnt solved the issue, but I didnt had a much time to debug it.


    Best regards,
    Jiri






    2018-09-14 12:33 GMT+02:00 vikrant8051 <vikrant8051@...>:

    Hi Carles,
    -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    >> Did you run addr2line in 0x20001c5c?


    ***** MPU FAULT *****                                                                                                           

      Instruction Access Violation                                                                                                   

    ***** Hardware exception *****                                                                                                   

    Current thread ID = 0x20001884                                                                                                   

    Faulting instruction address = 0x20001c88                                                                                       

    Fatal fault in ISR! Spinning...



    1)

    /opt/zephyr-sdk/sysroots/x86_64-pokysdk-linux/usr/bin/arm-zephyr-eabi/arm-zephyr-eabi-addr2line -e  /home/vikrant/zephyr/samples/boards/nrf52/mesh/onoff_level_lighting_vnd_app/build/zephyr/zephyr.elf
     0x20001c88


    &




    /opt/zephyr-sdk/sysroots/x86_64-pokysdk-linux/usr/bin/arm-zephyr-eabi/arm-zephyr-eabi-addr2line
     -e  /home/vikrant/zephyr/samples/boards/nrf52/mesh/onoff_level_lighting_vnd_app/build/zephyr/zephyr.elf 0x20001884


    Both returns -> :? ...... with zephyr-SDK


    2)

    I also tried to compile the App using latest gcc-arm-none-eabi-7-2018-q2



    2.1)

    /opt/gcc-arm-none-eabi-7-2018-q2-update/bin/arm-none-eabi-addr2line -e /home/vikrant/zephyr/samples/boards/nrf52/mesh/onoff_level_lighting_vnd_app/build/zephyr/zephyr.elf 0x20001c88



    o/p -> isr_tables.c:?


    2.2)

    /opt/gcc-arm-none-eabi-7-2018-q2-update/bin/arm-none-eabi-addr2line -e /home/vikrant/zephyr/samples/boards/nrf52/mesh/onoff_level_lighting_vnd_app/build/zephyr/zephyr.elf 0x20001884


    o/p -> /home/vikrant/zephyr/kernel/init.c:80

    -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    >> Have you tried increasing stack sizes?


    Yes.
    CONFIG_MAIN_STACK_SIZE=512 ....to 1024
    CONFIG_SYSTEM_WORKQUEUE_STACK_SIZE=2048 ....to 4096


    But still getting MPU Fault in case of Board executing BT Mesh Servers.













    On Fri, Sep 14, 2018 at 3:31 PM Cufi, Carles <Carles.Cufi@...> wrote:


    Hi there,

    Did you run addr2line in 0x20001c5c?
    Have you tried increasing stack sizes?

    Carles

    From:
    devel@... <mailto:devel@...> <devel@...>
    On Behalf Of vikrant8051
    Sent: 14 September 2018 11:48
    To:
    devel@... <mailto:devel@...>;
    users@... <mailto:users@...>
    Subject: Re: [Zephyr-devel] MPU fault while testing Bluetooth Mesh Sample demos



    Hi,



    FYI,

    With v1.12.99 I'm mot facing any MPU FAULT issue (while testing for #onoff_level_lighting_vnd_app)


    It has last commit -> ba6763a187a347cfc825a2bece78e7d1ef28772d



    That means something after it has changed the things bcz of that we are getting

    MPU FAULT.



    Thank You !!




    On Wed, Sep 5, 2018 at 10:50 AM vikrant8051 <vikrant8051@...> wrote:


    Hi,

    I'm getting following MPU fault while testing with samples for Bluetooth Mesh . This issue has started after syncing with master branch.



    ***** MPU FAULT *****                                                                                                           

      Instruction Access Violation                                                                                                   

    ***** Hardware exception *****                                                                                                   

    Current thread ID = 0x2000188c                                                                                                   

    Faulting instruction address = 0x20001c5c                                                                                       

    Fatal fault in ISR! Spinning...





    Thank You !!



























    --
    ===================================================
    Ing. Jiri Kubias

    e-mail: jiri.kubias@...
    mobile: 775 593 956
    ===================================================


















    --
    ===================================================
    Ing. Jiri Kubias

    e-mail: jiri.kubias@...
    mobile: 775 593 956
    ===================================================

Join users@lists.zephyrproject.org to automatically receive all group messages.