Re: cant perform west init


Carles Cufi
 

Hi Kay,

Can you make sure you have the latest colorama version?

pip3 install --user -U colorama

Carles

-----Original Message-----
From: users@lists.zephyrproject.org <users@lists.zephyrproject.org> On
Behalf Of Bolivar, Marti via Lists.Zephyrproject.Org
Sent: 03 July 2019 19:20
To: kayli0109@gmail.com; Herbert, Marc <marc.herbert@intel.com>
Cc: users@lists.zephyrproject.org
Subject: Re: [Zephyr-users] cant perform west init

" via Lists.Zephyrproject.Org"
<kayli0109=gmail.com@lists.zephyrproject.org> writes:

Hi Marc,

Thanks for the response.
In that case, can i install multiple version of Python? What version
of Python needed in this project?
Currently, Python 3.4+ is required.

Thanks,
Marti


Regards,
Kay Li

On Wed, 3 Jul 2019 at 10:07, Herbert, Marc <marc.herbert@intel.com>
wrote:

You have a very old Python version in your HOME directory, is that on
purpose? Does some other project require it maybe?



Marc



*From: *<users@lists.zephyrproject.org> on behalf of KAY LI NG <
kayli0109@gmail.com>
*Date: *Tuesday, 2 July 2019 at 18:15
*To: *"users@lists.zephyrproject.org" <users@lists.zephyrproject.org>
*Subject: *[Zephyr-users] cant perform west init



Hi there,



While performing west init, i face this issue.



$ west init zephyrproject



Traceback (most recent call last):

File "/home/gchee2/.local/bin/west", line 11, in <module>

sys.exit(main())

File
"/home/gchee2/.local/lib/python3.4/site-packages/west/_bootstrap/main
.py",
line 501, in main

init(wrap_argv[1:])

File
"/home/gchee2/.local/lib/python3.4/site-packages/west/_bootstrap/main
.py",
line 257, in init

bootstrap(args)

File
"/home/gchee2/.local/lib/python3.4/site-packages/west/_bootstrap/main
.py",
line 323, in bootstrap

exist_ok=True)

File
"/home/gchee2/.local/lib/python3.4/site-packages/west/_bootstrap/main
.py",
line 124, in clone

_banner('Cloning {} from {}, rev. {} into {}'.format(desc, url,
rev,
dest))

File
"/home/gchee2/.local/lib/python3.4/site-packages/west/_bootstrap/main
.py",
line 162, in _banner

print(colorama.Fore.LIGHTGREEN_EX, end='')

AttributeError: 'AnsiCodes' object has no attribute 'LIGHTGREEN_EX'



Some online resources say its the colorama version not up to date,
but i cant seems to upgrade it.



Any idea how to solve it?



Thank you!



Regards,

Kay Li


Join users@lists.zephyrproject.org to automatically receive all group messages.