Re: DTC version unsupported error #west


Lawrence King
 

Hi Eric:

 

You need to download and install a newer version of the Device Tree Compiler (dtc). Here is the easiest way I have found to do this:

 

wget http://mirrors.kernel.org/ubuntu/pool/main/d/device-tree-compiler/device-tree-compiler_1.4.7-1_amd64.deb

sudo apt install ./device-tree-compiler_1.4.7-1_amd64.deb

 

 

Lawrence King

Principal Developer

+1(416)627-7302

 

From: users@... <users@...> On Behalf Of Cufi, Carles
Sent: Monday, July 15, 2019 7:18 AM
To: tsai.eric.h@...; users@...
Subject: Re: [Zephyr-users] DTC version unsupported error #west

 

Hi Eric,

 

Can you try replacing $HOME in the ZEPHYR_SDK_INSTALL_DIR with the full path? I know I’ve seen issues with that in the past.

 

For example in my case I use:

 

ZEPHYR_SDK_INSTALL_DIR="/home/carles/bin/zephyr-sdk"

 

 

From: users@... <users@...> On Behalf Of Eric via Lists.Zephyrproject.Org
Sent: 06 July 2019 06:01
To: users@...
Cc: users@...
Subject: [Zephyr-users] DTC version unsupported error #west

 

On a new Ubuntu install, I'm having this issue with Zephyr using West.  It's also referenced in this issue, but the fix mentioned there didn't work for me:

https://github.com/zephyrproject-rtos/zephyr/issues/15246

$ west build -b nrf51_pca10031
-- west build: build configuration:
       source directory: /home/hp1/zephyrproject/zephyr/samples/hello_world
       build directory: /home/hp1/zephyrproject/zephyr/samples/hello_world/build
       BOARD: nrf51_pca10031 (origin: command line)
-- west build: generating a build system
Zephyr version: 1.14.99
-- Selected BOARD nrf51_pca10031
-- Found west: /home/hp1/.local/bin/west (found suitable version "0.5.7", minimum required is "0.5.6")
CMake Error at /home/hp1/zephyrproject/zephyr/cmake/extensions.cmake:1324 (message):
  Assertion failed: The detected dtc version is unsupported.

      The version was found to be 1.4.5                                  
      But the minimum supported version is 1.4.6                       
      See https://docs.zephyrproject.org/latest/getting_started/                    
      for how to use the SDK's dtc alongside a custom toolchain.
Call Stack (most recent call first):
  /home/hp1/zephyrproject/zephyr/cmake/host-tools.cmake:69 (assert)
  /home/hp1/zephyrproject/zephyr/cmake/app/boilerplate.cmake:412 (include)
  CMakeLists.txt:5 (include)


-- Configuring incomplete, errors occurred!


I did try the two environmental variables, which are now part of the Zephyr instructions, but the problem persists.

export ZEPHYR_TOOLCHAIN_VARIANT=zephyr
export ZEPHYR_SDK_INSTALL_DIR=$HOME/zephyr-sdk-0.10.1


I'm unsure how to go about fixing the DTC version issue.

Join users@lists.zephyrproject.org to automatically receive all group messages.