Error in services launch sequence #gdb #eclipse #debugging


Peter <nimac.peter@...>
 

Hello,

I am trying to setup Eclipse with GNU MCU Eclipse plugin as an IDE debugger for Zephyr under Ubuntu 19.04. That is mainly in hopes to be able to debug with multiple threads, since I can't seem to get the gdb to detect more than thread at a time, even with the application configured with CONFIG_OPENOCD_SUPPORT=y set. For the test I'm using the Philosophers example provided by Zephyr.

So far I've been following the guide in the zephyr documentation and completed the configuration, but when I try to debug the program I get the following error:

Error in services launch sequence
Launching command [/home/pnimac/.local/bin/pyocd gdbserver --port 3333 --telnet-port 4444 --frequency 8000000 --pack="/home/pnimac/pyocd-packs/Keil.STM32F4xx_DFP.2.14.0.pack" -c echo "Started by GNU MCU Eclipse"] failed.
Launching command [/home/pnimac/.local/bin/pyocd gdbserver --port 3333 --telnet-port 4444 --frequency 8000000 --pack="/home/pnimac/pyocd-packs/Keil.STM32F4xx_DFP.2.14.0.pack" -c echo "Started by GNU MCU Eclipse"] failed.
Cannot run program "/home/pnimac/.local/bin/pyocd gdbserver": Unknown reason
However, I can run the gdb debugger or simply flash the code just fine by using following commands:

west debug
west debugserver
west flash

Below are the screenshots of my configuration. I am passing the --pack option since I'm using STM Nucleo-144 F446ZE, which is not installed with pyOCD by default and I cannot install it using other means. Anyway, according to the error message it seems to me the command is called correctly. 



Any help is greatly appreciated.

Best regards!
Peter

Join users@lists.zephyrproject.org to automatically receive all group messages.