Re: Error in Getting Started Guide


Carles Cufi
 

Hi Jim,

 

Zephyr requires Python 3.6, you seem to be using Python 3.5.

 

Carles

 

 

From: users@... <users@...> On Behalf Of jim slaughter via lists.zephyrproject.org
Sent: 04 June 2020 00:33
To: users@...
Cc: jim slaughter <jim.slaughter@...>
Subject: [Zephyr-users] Error in Getting Started Guide

 

Hello,

 

I am new to Zephyr. Problem with Getting Started Guide, UBUNTU Tab

 

Get Zephyr and install Python dependencies

2. Get the Zephyr source code:  

1.  west init ~/zephyrproject

jws@DESKTOP-AJSFNLH:~$ west init ~/zephyrproject
Traceback (most recent call last):
  File "/home/jws/.local/bin/west", line 7, in <module>
    from west.app.main import main
  File "/home/jws/.local/lib/python3.5/site-packages/west/app/main.py", line 180
    log.die(f"file not found: {self.mle.filename}")                                              ^
SyntaxError: invalid syntax

 

Did I miss something in the instructions?

What is wrong?  Line 180

               # This should ordinarily only happen when the top
                # level west.yml is not found.
                log.die(f"file not found: {self.mle.filename}")

 

Thanks.

--

Jim Slaughter

Join users@lists.zephyrproject.org to automatically receive all group messages.