Re: [STM32L4] looks there is no way to flash and debug?


Carles Perello
 

After the build sequence

cmake -GNinja -DBOARD=nucleo_l432kc ..
ninja
[1/95] Generating always_rebuild
Building for board nucleo_l432kc
[90/95] Linking C executable zephyr/zephyr_prebuilt.elf
Memory region Used Size Region Size %age Used
FLASH: 11376 B 256 KB 4.34%
SRAM: 4576 B 64 KB 6.98%
IDT_LIST: 132 B 2 KB 6.45%
[95/95] Linking C executable zephyr/zephyr.elf

ninja flash
[0/1] Flashing nucleo_l432kc
flash is not supported with this board. Please check the documentation
for alternate instructions.

I am using zephyr release 1.11.0 under windows (using msys2)

regards

On Tue, Mar 13, 2018 at 9:41 AM, Erwan Gouriou <erwan.gouriou@...> wrote:
Hi Carles,


There is no particular limitation on STM32L4 that should prevent you to
flash and debug.
Can you provide us more details on your set up to understand what is going
on (board,
SW, environment, error you encounter..)?

Cheers
Erwan

On 13 March 2018 at 09:35, Carles Perello <carles.perello@...> wrote:

Hello

I am starting to do a development on STM32L4 nucleo based
boards....but seems that something is misconfigured as I cant do flash
or debug (either make or ninja).

Any pointer to what I can change to make is work is more than welcome :-)


regards

Carles
_______________________________________________
Zephyr-users mailing list
Zephyr-users@...
https://lists.zephyrproject.org/mailman/listinfo/zephyr-users

Join users@lists.zephyrproject.org to automatically receive all group messages.