Re: [Zephyr-devel] cmake -DBOARD=nrf52840_pca10056 .. gives me ERROR


vikrant8051 <vikrant8051@...>
 

Hi,
I re-downloaded entire git repository & now it works for me !!

On Thu, May 31, 2018 at 7:07 PM, vikrant8051 <vikrant8051@...> wrote:
Hi,
But I'm facing this error just after updating to latest version of zephyr which I did just an half hour ago.

Thank You !!

On Thu, May 31, 2018 at 7:02 PM, Bøe, Sebastian <Sebastian.Boe@...> wrote:
https://stackoverflow.com/questions/47081317/zephyr-cmake-error
________________________________________
From: devel@... <devel@...> on behalf of vikrant8051 <vikrant8051@...>
Sent: Thursday, 31 May 2018 3:20:09 PM
To: devel@...; users@...
Subject: [Zephyr-devel] cmake -DBOARD=nrf52840_pca10056 .. gives me ERROR

Hi,

After executing,
cmake -DBOARD=nrf52840_pca10056 ..

I got following error ...
(tried it with samples/bluetooth/mesh as well as samples/basic/blink_led/build)
-------------------------------------------------------------------------------------------------------------------------

CMake Error at CMakeLists.txt:1 (include):
  include could not find load file:

    /cmake/app/boilerplate.cmake


-- The C compiler identification is GNU 5.4.0
-- The CXX compiler identification is GNU 5.4.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:4 (target_sources):
  Cannot specify sources for target "app" which is not built by this project.


CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 3.5)

  should be added at the top of the file.  The version specified may be lower
  if you wish to support older CMake versions for this project.  For more
  information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!
See also "/home/vikrant/projects/zephyr/zephyr/samples/basic/blink_led/build/CMakeFiles/CMakeOutput.log".


Thank You !!



Join users@lists.zephyrproject.org to automatically receive all group messages.