Re: k_sleep on mimxrt1050_evk board


marco.hoefle@...
 

Hello Maureen,
thanks for the fix, now ksleep and timer API work as expected.
Ragreds,
Marco



Von: Maureen Helm [maureen.helm@...]
Gesendet: Freitag, 22. Juni 2018 16:55
An: Hoefle, Marco (Avnet Silica); users@...
Betreff: RE: [Zephyr-users] k_sleep on mimxrt1050_evk board

Hi Marco,

We traced the issue down to a difference in low-power mode behavior between A0 and A1 silicon (EVK and EVKB boards respectively). Please give the following PR a try:

https://github.com/zephyrproject-rtos/zephyr/pull/8535

 

Thanks,

Maureen

 

From: users@... [mailto:users@...] On Behalf Of Maureen Helm
Sent: Monday, June 18, 2018 4:15 PM
To: marco.hoefle@...; users@...
Subject: Re: [Zephyr-users] k_sleep on mimxrt1050_evk board

 

Hi Marco,

This board has two versions, EVK and EVKB, which correspond to different revisions of silicon (A0 and A1, respectively). The EVK board works just fine, but I was able to reproduce the issue on the EVKB board. There does appear to be a problem with the timer, but I’m still investigating.

 

Please go ahead and file a bug so we can track it.

 

Maureen

 

From: users@... [mailto:users@...] On Behalf Of marco.hoefle@...
Sent: Friday, June 15, 2018 12:48 AM
To: users@...
Subject: Re: [Zephyr-users] k_sleep on mimxrt1050_evk board

 

Hello Anas,
I will, I just let Maureen have a look first just in case I need to add something to the kernel config or I am doing something wrong.
Marco

Join users@lists.zephyrproject.org to automatically receive all group messages.