Date   

Re: Using printk on an STM32F103C8 board

Adam Podogrocki
 

Hi Scott,

if you are using board configuration file purposed for Nucleo F103RB, then the default UART configuration refers to UART2, pins TX=A2, RX=PA3. Pins configuration can be found in drivers/pinmux/stm32/pinmux_board_nucleo_f103rb.c.

If you would like to use UART1, then in menuconfig you have to modify settings for Serial drivers & Console drivers to match the desired UART port and baud rate.

Compile errors point out that the UART1 configuration is missing.

Please also take a look at e.g "dts/arm/nucleo_l476rg.fixup" file and do appropriate amendments in nucleo f103rb corresponding file.

Cheers,
Adam

On 21 May 2017 at 23:54, Scott Nelson <scott@...> wrote:
I’m trying to get Zephyr running on an STM32F103C8 "blue pill" board by using the similar nucleo_f103rb board config (with which I can successfully get an LED to blink).  I’m trying to setup printk by enabling CONFIG_UART_STM32_PORT_1=y (TX=PA9, RX=PA10) but I get the following compile errors: https://pastebin.com/raaww0a8

Am I missing additional config?

I was also planning on setting CONFIG_UART_CONSOLE_ON_DEV_NAME="UART_1" and CONFIG_PRINTK=y in hopes of being able to read printk messages via a USB-to-serial adapter.

-Scott
_______________________________________________
Zephyr-users mailing list
Zephyr-users@lists.zephyrproject.org
https://lists.zephyrproject.org/mailman/listinfo/zephyr-users


Using printk on an STM32F103C8 board

Scott Nelson <scott@...>
 

I’m trying to get Zephyr running on an STM32F103C8 "blue pill" board by using the similar nucleo_f103rb board config (with which I can successfully get an LED to blink). I’m trying to setup printk by enabling CONFIG_UART_STM32_PORT_1=y (TX=PA9, RX=PA10) but I get the following compile errors: https://pastebin.com/raaww0a8

Am I missing additional config?

I was also planning on setting CONFIG_UART_CONSOLE_ON_DEV_NAME="UART_1" and CONFIG_PRINTK=y in hopes of being able to read printk messages via a USB-to-serial adapter.

-Scott


Re: Zephyr in use with Arduino

Justin
 

Of course you can do that without writing a driver. You can't send your code to Zephyr though and expect it to be added if it's not part of a driver. You can do whatever you want in your own project.


On Thu, May 18, 2017 at 10:08 AM Kevin Stöckl <k_stoeckl@...> wrote:

Okay Thank you. 


so would it be better to take a Uart TTL Serial Camera? Is there a possibility to communicate with the camera without writing a driver?




Von: Justin Watson <jwatson5@...>
Gesendet: Donnerstag, 18. Mai 2017 18:44
An: Kevin Stöckl; zephyr-users@...
Betreff: Re: [Zephyr-users] Zephyr in use with Arduino
 
The Arduino Due has USB host, but I don't think support will be added anytime soon for that. You will need USB host support to connect the webcam to the board. There is no easy connection to the internet for the Arduino Due board either. You could add an external WiFi chip or external BLE chip, which you would have to write the driver for. The BLE might work because Zephyr currently has a lot of BLE support. However, you won't be able to sent high resolution images because BLE is low bandwidth.

The Arduino 101 looks like it has USB, but I haven't been able to find the datasheet for the chip to see if it supports host. Even then you will need to write the host driver. The board does come with BLE on it, which may already work with Zephyr. I don't know for sure. I will check in the next few days or you can check.

Getting the data from the webcam is going to take a board with USB host though that's going to be the most difficult part because no board has USB host support right now.

As far as getting the data to the internet you really need a board with Ethernet or Wifi because video is high bandwidth.

On Thu, May 18, 2017 at 7:35 AM Kevin Stöckl <k_stoeckl@...> wrote:

Hello,

I am trying to make a security camera with zephyr and Arduino and therefore I had some Questions.


1. Which Arduino will be the best for this Application? "Due" or "101"?

2. How can I turn on a USB Webcam when it is necessary?

3. Is it possible to get a Internet Connection with the Arduino Due?


Thanks in Advance

Kevin

_______________________________________________
Zephyr-users mailing list
Zephyr-users@...
https://lists.zephyrproject.org/mailman/listinfo/zephyr-users


Re: Zephyr in use with Arduino

Kevin Stöckl <k_stoeckl@...>
 

Okay Thank you. 


so would it be better to take a Uart TTL Serial Camera? Is there a possibility to communicate with the camera without writing a driver?




Von: Justin Watson <jwatson5@...>
Gesendet: Donnerstag, 18. Mai 2017 18:44
An: Kevin Stöckl; zephyr-users@...
Betreff: Re: [Zephyr-users] Zephyr in use with Arduino
 
The Arduino Due has USB host, but I don't think support will be added anytime soon for that. You will need USB host support to connect the webcam to the board. There is no easy connection to the internet for the Arduino Due board either. You could add an external WiFi chip or external BLE chip, which you would have to write the driver for. The BLE might work because Zephyr currently has a lot of BLE support. However, you won't be able to sent high resolution images because BLE is low bandwidth.

The Arduino 101 looks like it has USB, but I haven't been able to find the datasheet for the chip to see if it supports host. Even then you will need to write the host driver. The board does come with BLE on it, which may already work with Zephyr. I don't know for sure. I will check in the next few days or you can check.

Getting the data from the webcam is going to take a board with USB host though that's going to be the most difficult part because no board has USB host support right now.

As far as getting the data to the internet you really need a board with Ethernet or Wifi because video is high bandwidth.

On Thu, May 18, 2017 at 7:35 AM Kevin Stöckl <k_stoeckl@...> wrote:

Hello,

I am trying to make a security camera with zephyr and Arduino and therefore I had some Questions.


1. Which Arduino will be the best for this Application? "Due" or "101"?

2. How can I turn on a USB Webcam when it is necessary?

3. Is it possible to get a Internet Connection with the Arduino Due?


Thanks in Advance

Kevin

_______________________________________________
Zephyr-users mailing list
Zephyr-users@...
https://lists.zephyrproject.org/mailman/listinfo/zephyr-users


Re: Zephyr in use with Arduino

Justin
 

The Arduino Due has USB host, but I don't think support will be added anytime soon for that. You will need USB host support to connect the webcam to the board. There is no easy connection to the internet for the Arduino Due board either. You could add an external WiFi chip or external BLE chip, which you would have to write the driver for. The BLE might work because Zephyr currently has a lot of BLE support. However, you won't be able to sent high resolution images because BLE is low bandwidth.

The Arduino 101 looks like it has USB, but I haven't been able to find the datasheet for the chip to see if it supports host. Even then you will need to write the host driver. The board does come with BLE on it, which may already work with Zephyr. I don't know for sure. I will check in the next few days or you can check.

Getting the data from the webcam is going to take a board with USB host though that's going to be the most difficult part because no board has USB host support right now.

As far as getting the data to the internet you really need a board with Ethernet or Wifi because video is high bandwidth.

On Thu, May 18, 2017 at 7:35 AM Kevin Stöckl <k_stoeckl@...> wrote:

Hello,

I am trying to make a security camera with zephyr and Arduino and therefore I had some Questions.


1. Which Arduino will be the best for this Application? "Due" or "101"?

2. How can I turn on a USB Webcam when it is necessary?

3. Is it possible to get a Internet Connection with the Arduino Due?


Thanks in Advance

Kevin

_______________________________________________
Zephyr-users mailing list
Zephyr-users@...
https://lists.zephyrproject.org/mailman/listinfo/zephyr-users


Zephyr in use with Arduino

Kevin Stöckl <k_stoeckl@...>
 

Hello,

I am trying to make a security camera with zephyr and Arduino and therefore I had some Questions.


1. Which Arduino will be the best for this Application? "Due" or "101"?

2. How can I turn on a USB Webcam when it is necessary?

3. Is it possible to get a Internet Connection with the Arduino Due?


Thanks in Advance

Kevin


Re: [Zephyr-devel] I2C or SPI Driver Example for ARC (Sensor subsystem) for Quark_se

Chuck Jordan <Chuck.Jordan@...>
 

Be sure to also get the data sheet for the device attached to SPI or I2C.
There are configurable options you must do correctly to communicate properly to the device on the other side.

-----Original Message-----
From: zephyr-devel-bounces@lists.zephyrproject.org [mailto:zephyr-devel-bounces@lists.zephyrproject.org] On Behalf Of Bogdan Davidoaia
Sent: Thursday, May 11, 2017 1:00 AM
To: Mahendravarman Rajarao (RBEI/EAA10) <Mahendravarman.Rajarao@in.bosch.com>
Cc: devel@lists.zephyrproject.org; users@lists.zephyrproject.org
Subject: Re: [Zephyr-devel] I2C or SPI Driver Example for ARC (Sensor subsystem) for Quark_se

Hello,

Although they are not specific to ARC, you can look over most of the sensor drivers (in drivers/sensor/) for use of I2C and SPI.

Use of the I2C/SPI API is the same regardless of the platform, so it should be an ok starting point.

Regards,
Bogdan



On 11 May 2017 at 08:12, Mahendravarman Rajarao (RBEI/EAA10) <Mahendravarman.Rajarao@in.bosch.com> wrote:


Hi Team



Do you have any sample/example of Using I2C or SPI driver of ARC (
sensor
subsystem) in Quark_se ?



Thanks






_______________________________________________
Zephyr-devel mailing list
Zephyr-devel@lists.zephyrproject.org
https://urldefense.proofpoint.com/v2/url?u=https-3A__lists.zephyrproje
ct.org_mailman_listinfo_zephyr-2Ddevel&d=DwICAg&c=DPL6_X_6JkXFx7AXWqB0
tg&r=Ur8eT0ZY1DOjJtZ8biKXp_CyOvecmZtsphp7SXIsE1Y&m=nirrrHvTYPm_ezoRVKS
QRHEVyJyfsiT6yrNJC04V0C0&s=rW_84jfRfJ5BSA2GSTM_0-tJAVqNHs73iLJNKcJ0FtI
&e=
_______________________________________________
Zephyr-devel mailing list
Zephyr-devel@lists.zephyrproject.org
https://urldefense.proofpoint.com/v2/url?u=https-3A__lists.zephyrproject.org_mailman_listinfo_zephyr-2Ddevel&d=DwICAg&c=DPL6_X_6JkXFx7AXWqB0tg&r=Ur8eT0ZY1DOjJtZ8biKXp_CyOvecmZtsphp7SXIsE1Y&m=nirrrHvTYPm_ezoRVKSQRHEVyJyfsiT6yrNJC04V0C0&s=rW_84jfRfJ5BSA2GSTM_0-tJAVqNHs73iLJNKcJ0FtI&e=


Re: [Zephyr-devel] I2C or SPI Driver Example for ARC (Sensor subsystem) for Quark_se

Dinh, Kien T <kien.t.dinh@...>
 

Have you looked at the gpio sample under samples/drivers/gpio?

 

It’s just “GPIO_0”, and it depends whether the app is built for ARC or x86.

For x86, it can be built with:

$ make BOARD=arduino_101

And for ARC, it can be built with

$ make BOARD=arduino_101_sss

 

Regards,

Kien

 

From: "Mahendravarman Rajarao (RBEI/EAA10)" <Mahendravarman.Rajarao@...>
Date: Thursday, May 11, 2017 18:35
To: Kien Dinh <kien.t.dinh@...>, "users@..." <users@...>, "devel@..." <devel@...>
Cc: Bogdan Davidoaia <bogdan.davidoaia@...>
Subject: RE: [Zephyr-devel] I2C or SPI Driver Example for ARC (Sensor subsystem) for Quark_se

 

Hi

 

Iam using zephyr 1.6.0 downloaded from the site

 

If I need to toggle a simple GPIO on the Sensor subsystem, In the Kconfig file of the ARC

Config options given are GPIO_QMSI , GPIO_QMSI_SS & GPIO_QMSI_SS_0_NAME (default name is GPIO_SS_0)

 

So In device binding we need to give as device_get_binding(“GPIO_SS_0”);

If I give as device_get_binding(“GPIO_0”); then x86 gpio is toggling.

 

Can you confirm this ?

 

 

Do you have any example of gpio with sensor subsystem ?

 

 

 

Thanks


From: Dinh, Kien T [mailto:kien.t.dinh@...]
Sent: Thursday, May 11, 2017 2:41 PM
To: Mahendravarman Rajarao (RBEI/EAA10) <Mahendravarman.Rajarao@...>; users@...; devel@...
Subject: Re: [Zephyr-devel] I2C or SPI Driver Example for ARC (Sensor subsystem) for Quark_se

 

Hi Mahendravarman,

 

You might try to look at the samples folder in the repository. The below examples are using I2C and SPI on ARC:

https://github.com/zephyrproject-rtos/zephyr/tree/master/samples/drivers/current_sensing

https://github.com/zephyrproject-rtos/zephyr/tree/master/samples/environmental_sensing

https://github.com/zephyrproject-rtos/zephyr/tree/master/samples/sensor/bme280

 

Regards,

Kien

 

 

From: <zephyr-devel-bounces@...> on behalf of "Mahendravarman Rajarao (RBEI/EAA10)" <Mahendravarman.Rajarao@...>
Date: Thursday, May 11, 2017 14:12
To: "
users@..." <users@...>, "devel@..." <devel@...>
Subject: [Zephyr-devel] I2C or SPI Driver Example for ARC (Sensor subsystem) for Quark_se

 

 

Hi Team

 

Do you have any sample/example of Using I2C or SPI driver of ARC ( sensor subsystem) in Quark_se ?

 

Thanks

 

 


Re: [Zephyr-devel] I2C or SPI Driver Example for ARC (Sensor subsystem) for Quark_se

Mahendravarman Rajarao (RBEI/EAA10) <Mahendravarman.Rajarao@...>
 

Hi

 

Iam using zephyr 1.6.0 downloaded from the site

 

If I need to toggle a simple GPIO on the Sensor subsystem, In the Kconfig file of the ARC

Config options given are GPIO_QMSI , GPIO_QMSI_SS & GPIO_QMSI_SS_0_NAME (default name is GPIO_SS_0)

 

So In device binding we need to give as device_get_binding(“GPIO_SS_0”);

If I give as device_get_binding(“GPIO_0”); then x86 gpio is toggling.

 

Can you confirm this ?

 

 

Do you have any example of gpio with sensor subsystem ?

 

 

 

Thanks

From: Dinh, Kien T [mailto:kien.t.dinh@...]
Sent: Thursday, May 11, 2017 2:41 PM
To: Mahendravarman Rajarao (RBEI/EAA10) <Mahendravarman.Rajarao@...>; users@...; devel@...
Subject: Re: [Zephyr-devel] I2C or SPI Driver Example for ARC (Sensor subsystem) for Quark_se

 

Hi Mahendravarman,

 

You might try to look at the samples folder in the repository. The below examples are using I2C and SPI on ARC:

https://github.com/zephyrproject-rtos/zephyr/tree/master/samples/drivers/current_sensing

https://github.com/zephyrproject-rtos/zephyr/tree/master/samples/environmental_sensing

https://github.com/zephyrproject-rtos/zephyr/tree/master/samples/sensor/bme280

 

Regards,

Kien

 

 

From: <zephyr-devel-bounces@...> on behalf of "Mahendravarman Rajarao (RBEI/EAA10)" <Mahendravarman.Rajarao@...>
Date: Thursday, May 11, 2017 14:12
To: "
users@..." <users@...>, "devel@..." <devel@...>
Subject: [Zephyr-devel] I2C or SPI Driver Example for ARC (Sensor subsystem) for Quark_se

 

 

Hi Team

 

Do you have any sample/example of Using I2C or SPI driver of ARC ( sensor subsystem) in Quark_se ?

 

Thanks

 

 


Re: [Zephyr-devel] I2C or SPI Driver Example for ARC (Sensor subsystem) for Quark_se

Dinh, Kien T <kien.t.dinh@...>
 

Hi Mahendravarman,

 

You might try to look at the samples folder in the repository. The below examples are using I2C and SPI on ARC:

https://github.com/zephyrproject-rtos/zephyr/tree/master/samples/drivers/current_sensing

https://github.com/zephyrproject-rtos/zephyr/tree/master/samples/environmental_sensing

https://github.com/zephyrproject-rtos/zephyr/tree/master/samples/sensor/bme280

 

Regards,

Kien

 

 

From: <zephyr-devel-bounces@...> on behalf of "Mahendravarman Rajarao (RBEI/EAA10)" <Mahendravarman.Rajarao@...>
Date: Thursday, May 11, 2017 14:12
To: "users@..." <users@...>, "devel@..." <devel@...>
Subject: [Zephyr-devel] I2C or SPI Driver Example for ARC (Sensor subsystem) for Quark_se

 

 

Hi Team

 

Do you have any sample/example of Using I2C or SPI driver of ARC ( sensor subsystem) in Quark_se ?

 

Thanks

 

 


Re: [Zephyr-devel] I2C or SPI Driver Example for ARC (Sensor subsystem) for Quark_se

Bogdan Davidoaia
 

Hello,

Although they are not specific to ARC, you can look over most of the
sensor drivers (in drivers/sensor/) for use of I2C and SPI.

Use of the I2C/SPI API is the same regardless of the platform, so it
should be an ok starting point.

Regards,
Bogdan



On 11 May 2017 at 08:12, Mahendravarman Rajarao (RBEI/EAA10)
<Mahendravarman.Rajarao@in.bosch.com> wrote:


Hi Team



Do you have any sample/example of Using I2C or SPI driver of ARC ( sensor
subsystem) in Quark_se ?



Thanks






_______________________________________________
Zephyr-devel mailing list
Zephyr-devel@lists.zephyrproject.org
https://lists.zephyrproject.org/mailman/listinfo/zephyr-devel


I2C or SPI Driver Example for ARC (Sensor subsystem) for Quark_se

Mahendravarman Rajarao (RBEI/EAA10) <Mahendravarman.Rajarao@...>
 

 

Hi Team

 

Do you have any sample/example of Using I2C or SPI driver of ARC ( sensor subsystem) in Quark_se ?

 

Thanks

 

 


★ Leia suas mensagens antes que sejam deletadas

Felipe Neves
 

Badoo
See this email in English, Deutsch, Français, Italiano, Español or 37 other languages
Felipe te enviou uma mensagem
Você ainda não leu a mensagem enviada por Felipe. Leia antes que seja deletada!
Outras pessoas perto de você:
App Store Google Play Windows Store


I2C or SPI Driver Example for ARC (Sensor subsystem) for Quark_se

Mahendravarman Rajarao (RBEI/EAA10) <Mahendravarman.Rajarao@...>
 

Hi Team

 

Do you have any sample/example of Using I2C or SPI driver of ARC ( sensor subsystem) in Quark_se ?

 

Thanks

 

 


★ Zephyr Users, Felipe te mandou uma mensagem

Felipe Neves
 


using Intel ISSM tolos to compile arduino_101_sss

Carles Perello
 

Hi

While having no issues using Intel ISSM toolkit on arduino_101, when I try to compile using arduino_101_sss as target, it complains that

arc-elf32-gcc.exe: error: unrecognized argument in option '-mcpu=quarkse_em'

what would be the apropiate cpu to use on ISSM tools?


cheers


[net]Why not respond RS message

guiwu.guo <hfggw@...>
 

Hi all,

I am development a Ipv6 project now, I have enable the CONFIG_NET_IPV6_ND.
But when the connection establish between two note, the note doesn't processing the RS message.
the log is like this:
[net/core] [DBG] net_recv_data: (0x200092b8): fifo 0x20003620 iface 0x20000e60 pkt 0x20008fa4 len 28
[net/core] [INF] net_analyze_stack: net (0x200081a4): RX thread stack real size 1596 unused 796 usage 704/1500 (43 %)
[net/core] [DBG] net_rx_thread: (0x200081a4): Received pkt 0x20008fa4 len 28
[net/ipv6] [DBG] net_ipv6_process_pkt: (0x200081a4): IPv6 packet len 56 received from fe80::d2af:d0ff:fe36:f04d to ff02::1
[net/ipv6] [DBG] process_icmpv6_pkt: (0x200081a4): ICMPv6 Router Solicitation received type 133 code 0
[net/core] [DBG] processing_data: (0x200081a4): Dropping pkt 0x20008fa4
In the code of icmpv6 that only register the request handler of echo_request:
static struct net_icmpv6_handler echo_request_handler = {
.type = NET_ICMPV6_ECHO_REQUEST,
.code = 0,
.handler = handle_echo_request,
};
Does it loss RS request processing in icmpv6?

Thanks,
Guiwu.guo


Re: Reg: Enable arc to access the spi controller on I/O fabric on C1000

Michael Rosen
 

1. I have declared CONFIG_SPI in the prj.conf for the ARC project and SPI access is working.
Can I declare the CONFIG_ SPI on the prj.conf on the X86 also ?
My query is simultaneous SPI access is possible via ARC and X86 ? or should we declare CONFIG_SPI in any one of the cores only.
You can, just be aware that there isn't any builtin mutual exclusion between the x86 and ARC cores in the OS, so if both cores are trying to access the same SPI controller, there will likely be concurrency issues. But it should be perfectly fine to use SPI0 from x86 and SPI1 from ARC (just be aware there still might be issues if you attempt to clock gate the controllers from both cores). Just be sure to disable the SPI controller you aren't using on the core that isn't using it or the interrupt routing will break things (wrong core responding to the interrupt).

x86.conf:

CONFIG_SPI=y
CONFIG_SPI_QMSI=y
CONFIG_SPI_0=y
CONFIG_SPI_1=n

arc.conf:

CONFIG_SPI=y
CONFIG_SPI_QMSI=y
CONFIG_SPI_0=n
CONFIG_SPI_1=y

2. After reset of C1000, the code in the ARC is getting executed first, Followed by x86 .
By default can I make some settings to delay the execution of ARC code  other than task_sleep ?
You can make sure ARC starts later if you modify the following file (unfortunately, the option isn't Kconfig'able):
arch/x86/soc/intel_quark/quark_se/soc.c

And modify the priority under SYS_INIT to be later. However, if you want it to happen AFTER the x86 application starts, youll need to still modify that file to remove the SYS_INIT and add this to your application:

extern int _arc_init(struct dev* arg);

// use in app like so
// if (_arc_init(NULL)) {
// printk("ARC initialization failed!\n");
// }

Its pretty ugly, but functional. You will still need CONFIG_ARC_INIT=y to build the _arc_init function.

Mike


Reg: Enable arc to access the spi controller on I/O fabric on C1000

Mahendravarman Rajarao (RBEI/EAA10) <Mahendravarman.Rajarao@...>
 

Hi

 

Please help me on the following queries

 

I have downloaded zephyr 1.6 and I have applied the patch https://gerrit.zephyrproject.org/r/#/c/8708/ to Enable arc to access the spi controller on I/O fabric.

 

I have few queries on the above.

 

1.      I have declared CONFIG_SPI in the prj.conf for the ARC project and SPI access is working.

Can I declare the CONFIG_ SPI on the prj.conf on the X86 also ?

My query is simultaneous SPI access is possible via ARC and X86 ? or should we declare CONFIG_SPI in any one of the cores only.

 

2.      After reset of C1000, the code in the ARC is getting executed first, Followed by x86 .

By default can I make some settings to delay the execution of ARC code  other than task_sleep ?

 

 

     

 

 

Best regards
Mahendra


Arduino 101 - pinmax of pins with multiple connections.

Graham Stott <gbcstott1@...>
 

My project only needs two PWM outputs so I want to switch the two unused PWM to GPIOs. The best candidates are PWM 0 (IO 3) and PWM 1 (IO 5) however these are the pins that are connected to another output pin from Curie.  Curie pins B1 and H1 go to IO-3 and A3 and G2 go to IO-5.  The GPIOs that I want to switch to, are on the other Curie output pins. For example GPIO 17 comes from pin B1 while PWM 0 comes from H1.

 

I believe that I need to put the unused pin in a high impedance mode so that it does not affect the other pin. I do not see any were in Zephyr where this is done so I presume that the OS assumes that the hardware comes up in this state and therefore it only does the pinmax for the pin to IO-3 and IO-5 that it wants. Note that there are in fact three other pins that are like this (IO-11, IO-12 and IO-13) which the documentation does not mention. The documentation is not helpful as it just says “IO-3 and IO-5 require both pins to be set for functionality changes. I did look at the pinmux.c and the header files but they were not helpful.

 

Can anyone point me to an example where/how this is done.   I looked at the sample code and online and could not find anything.

 

My guess is that I need to put the unused pin in input mode with no pull up and then pinmux the other pin to the output I want.

 

Graham

2641 - 2660 of 2694