Help needed for Zephyr compilation


Carles Cufi
 

Hi there,

Note that the Getting Started guides have been updated to use a requirements.txt instead of manually installing a set of Python modules. If you run pip against that .txt file it should install all required deps.

Thanks,

Carles

-----Original Message-----
From: zephyr-users-bounces@lists.zephyrproject.org [mailto:zephyr-users-
bounces@lists.zephyrproject.org] On Behalf Of Vakul Garg
Sent: 02 August 2017 10:07
To: massimiliano cialdi <massimiliano.cialdi@powersoft.it>; zephyr-
users@lists.zephyrproject.org
Subject: Re: [Zephyr-users] Help needed for Zephyr compilation

Thanks, it worked for me too.

-----Original Message-----
From: zephyr-users-bounces@lists.zephyrproject.org [mailto:zephyr-users-
bounces@lists.zephyrproject.org] On Behalf Of massimiliano cialdi
Sent: Tuesday, August 01, 2017 5:49 PM
To: zephyr-users@lists.zephyrproject.org
Subject: Re: [Zephyr-users] Help needed for Zephyr compilation

I had the same problem, and I solved it installing pyelftool 0.24

pip3 install pyelftools==0.24

best regards
Max
On 01/08/2017 12:43, Vakul Garg wrote:

Hi

I am newbie to Zephyr and compiling source from HEAD of master branch
for target qemu_x86.

I am getting following error.

Traceback (most recent call last):

File "/home/b16394/zephyr/zephyr-git/scripts/gen_offset_header.py",
line 8, in <module>

from elftools.elf.elffile import ELFFile

ImportError: No module named 'elftools'

make[3]: *** [include/generated/offsets.h] Error 1

make[2]: *** [prepare] Error 2

make[1]: *** [sub-make] Error 2

Can someone please help?

I could compile from below mentioned commit, but compiling latest code
fails with above error.

commit bc2454fa9e966ab31db6b78439389f9066f840b3

Regards

Vakul



_______________________________________________
Zephyr-users mailing list
Zephyr-users@lists.zephyrproject.org
https://lists.zephyrproject.org/mailman/listinfo/zephyr-users
_______________________________________________
Zephyr-users mailing list
Zephyr-users@lists.zephyrproject.org
https://lists.zephyrproject.org/mailman/listinfo/zephyr-users
_______________________________________________
Zephyr-users mailing list
Zephyr-users@lists.zephyrproject.org
https://lists.zephyrproject.org/mailman/listinfo/zephyr-users


Vakul Garg <vakul.garg@...>
 

Thanks, it worked for me too.

-----Original Message-----
From: zephyr-users-bounces@lists.zephyrproject.org [mailto:zephyr-users-bounces@lists.zephyrproject.org] On Behalf Of massimiliano cialdi
Sent: Tuesday, August 01, 2017 5:49 PM
To: zephyr-users@lists.zephyrproject.org
Subject: Re: [Zephyr-users] Help needed for Zephyr compilation

I had the same problem, and I solved it installing pyelftool 0.24

pip3 install pyelftools==0.24

best regards
Max
On 01/08/2017 12:43, Vakul Garg wrote:

Hi

I am newbie to Zephyr and compiling source from HEAD of master branch
for target qemu_x86.

I am getting following error.

Traceback (most recent call last):

File "/home/b16394/zephyr/zephyr-git/scripts/gen_offset_header.py",
line 8, in <module>

from elftools.elf.elffile import ELFFile

ImportError: No module named 'elftools'

make[3]: *** [include/generated/offsets.h] Error 1

make[2]: *** [prepare] Error 2

make[1]: *** [sub-make] Error 2

Can someone please help?

I could compile from below mentioned commit, but compiling latest code
fails with above error.

commit bc2454fa9e966ab31db6b78439389f9066f840b3

Regards

Vakul



_______________________________________________
Zephyr-users mailing list
Zephyr-users@lists.zephyrproject.org
https://lists.zephyrproject.org/mailman/listinfo/zephyr-users
_______________________________________________
Zephyr-users mailing list
Zephyr-users@lists.zephyrproject.org
https://lists.zephyrproject.org/mailman/listinfo/zephyr-users


Massimiliano Cialdi
 

I had the same problem, and I solved it installing pyelftool 0.24

pip3 install pyelftools==0.24

best regards
Max

On 01/08/2017 12:43, Vakul Garg wrote:

Hi

I am newbie to Zephyr and compiling source from HEAD of master branch for target qemu_x86.

I am getting following error.

Traceback (most recent call last):

File "/home/b16394/zephyr/zephyr-git/scripts/gen_offset_header.py", line 8, in <module>

from elftools.elf.elffile import ELFFile

ImportError: No module named 'elftools'

make[3]: *** [include/generated/offsets.h] Error 1

make[2]: *** [prepare] Error 2

make[1]: *** [sub-make] Error 2

Can someone please help?

I could compile from below mentioned commit, but compiling latest code fails with above error.

commit bc2454fa9e966ab31db6b78439389f9066f840b3

Regards

Vakul



_______________________________________________
Zephyr-users mailing list
Zephyr-users@lists.zephyrproject.org
https://lists.zephyrproject.org/mailman/listinfo/zephyr-users


Adam Podogrocki
 

Seems that the Python module named 'elftools' is missing. Please install the mentioned packed and try again.

Cheers,
Adam

On 1 August 2017 at 12:43, Vakul Garg <vakul.garg@...> wrote:

Hi

 

I am newbie to Zephyr and compiling source from HEAD of master branch for target qemu_x86.

I am getting following error.

 

Traceback (most recent call last):

  File "/home/b16394/zephyr/zephyr-git/scripts/gen_offset_header.py", line 8, in <module>

    from elftools.elf.elffile import ELFFile

ImportError: No module named 'elftools'

make[3]: *** [include/generated/offsets.h] Error 1

make[2]: *** [prepare] Error 2

make[1]: *** [sub-make] Error 2

 

Can someone please help?

I could compile from below mentioned commit, but compiling latest code fails with above error.

 

commit bc2454fa9e966ab31db6b78439389f9066f840b3

 

Regards

 

Vakul

 

 


_______________________________________________
Zephyr-users mailing list
Zephyr-users@lists.zephyrproject.org
https://lists.zephyrproject.org/mailman/listinfo/zephyr-users



Vakul Garg <vakul.garg@...>
 

Hi

 

I am newbie to Zephyr and compiling source from HEAD of master branch for target qemu_x86.

I am getting following error.

 

Traceback (most recent call last):

  File "/home/b16394/zephyr/zephyr-git/scripts/gen_offset_header.py", line 8, in <module>

    from elftools.elf.elffile import ELFFile

ImportError: No module named 'elftools'

make[3]: *** [include/generated/offsets.h] Error 1

make[2]: *** [prepare] Error 2

make[1]: *** [sub-make] Error 2

 

Can someone please help?

I could compile from below mentioned commit, but compiling latest code fails with above error.

 

commit bc2454fa9e966ab31db6b78439389f9066f840b3

 

Regards

 

Vakul