Topics

stm3210c_eval flashing via openocd dfu fails #stm32 #flash


PeterFromSwe
 

I am trying Zephyr for first time and just want to get going on an example on an available evaluation board.
I found a match for:
https://docs.zephyrproject.org/latest/boards/arm/stm3210c_eval/doc/index.html
It was not very straitforward to follow since acquaintance with Zephyr is assumed.
In my case Windows host is used, so openocd install is left out in instruction.

Where I get stuck

Flashing over DFU works fine if done with ST supplied SW, but not as per instruction:

C:\Users\peterfromswe\Documents\Temp\zephyrproject\zephyr\samples\basic\blinky\build>ninja flash
[0/1] Flashing stm3210c_eval
Using runner: openocd
Open On-Chip Debugger 0.10.0 (2019-02-10) [https://github.com/sysprogs/openocd]
Licensed under GNU GPL v2
For bug reports, read
        http://openocd.org/doc/doxygen/bugs.html
Error: Debug adapter does not support any transports? Check config file order.
Error: unable to select a session transport. Can't continue.
shutdown command invoked
Any ideas on how to proceed?
/Peter
 


Kumar Gala
 

Adding Erwan to see if he might have some insight.

- k

On Apr 11, 2019, at 1:44 AM, PeterFromSwe <@PeterFromSwe> wrote:

I am trying Zephyr for first time and just want to get going on an example on an available evaluation board.
I found a match for:
https://docs.zephyrproject.org/latest/boards/arm/stm3210c_eval/doc/index.html
It was not very straitforward to follow since acquaintance with Zephyr is assumed.
In my case Windows host is used, so openocd install is left out in instruction.
Where I get stuck

Flashing over DFU works fine if done with ST supplied SW, but not as per instruction:

C:\Users\peterfromswe\Documents\Temp\zephyrproject\zephyr\samples\basic\blinky\build>ninja flash
[0/1] Flashing stm3210c_eval
Using runner: openocd
Open On-Chip Debugger 0.10.0 (2019-02-10) [https://github.com/sysprogs/openocd]
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
Error: Debug adapter does not support any transports? Check config file order.
Error: unable to select a session transport. Can't continue.
shutdown command invoked
Any ideas on how to proceed?
/Peter