#stm32 build failure #stm32


alt.mcarter@...
 

I think I sent a private reply rather than to group. Let me try again ...
Which version of which toolchain are you using, and which version of zephyr?
Everything is a recent install.
zephyr-sdk-0.13.0

Version of zephyr I'm using:
commit fcfe597e5dadb96ecef5d6e8c82ffc99b5f4d59c (HEAD -> main, origin/main, origin/HEAD)
Author: Iuliana Prodan <iuliana.prodan@...>
Date:   Sat Aug 28 01:08:19 2021 +0300
OK, so now I checkout tag zephyr-v2.6.0.

Then I do
rm -rf build

mkdir build

cd build

cmake ..

I get
Including boilerplate (Zephyr base): /home/pi/zephyrproject/zephyr/cmake/app/boilerplate.cmake
CMake Deprecation Warning at /home/pi/zephyrproject/zephyr/cmake/app/boilerplate.cmake:37 (cmake_policy):
  The OLD behavior for policy CMP0079 will be removed from a future version
  of CMake.

  The cmake-policies(7) manual explains that the OLD behaviors of all
  policies are deprecated and that a policy should be set to OLD only under
  specific short-term circumstances.  Projects should be ported to the NEW
  behavior and not rely on setting a policy to OLD.

I had that before, though.

My errors are now:
Parsing /home/pi/zephyrproject/zephyr/Kconfig
/home/pi/zephyrproject/zephyr/scripts/kconfig/kconfig.py: /home/pi/zephyrproject/my_blinky/build/Kconfig/Kconfig.modules:2: Could not open '/home/pi/zephyrproject/zephyr/' (in 'osource "$(ZEPHYR_CANOPENNODE_KCONFIG)"') (EISDIR: Is a directory)
CMake Error at /home/pi/zephyrproject/zephyr/cmake/kconfig.cmake:264 (message):
  command failed with return code: 1
Call Stack (most recent call first):
  /home/pi/zephyrproject/zephyr/cmake/app/boilerplate.cmake:565 (include)
  /home/pi/zephyrproject/zephyr/share/zephyr-package/cmake/ZephyrConfig.cmake:24 (include)
  /home/pi/zephyrproject/zephyr/share/zephyr-package/cmake/ZephyrConfig.cmake:35 (include_boilerplate)
  CMakeLists.txt:4 (find_package)


-- Configuring incomplete, errors occurred!


Nick Stoughton
 

Which version of which toolchain are you using, and which version of zephyr?
-- 
Nick


On Tue, Aug 31, 2021 at 11:34 AM <alt.mcarter@...> wrote:
I'm trying to build a project. I'm getting:
 48%] Building ASM object zephyr/arch/arch/arm/core/aarch32/CMakeFiles/arch__arm__core__aarch32.dir/cpu_idle.S.obj
cc: warning: '-mcpu=' is deprecated; use '-mtune=' or '-march=' instead
cc: error: unrecognized argument in option '-mabi=aapcs'
cc: note: valid arguments to '-mabi=' are: ms sysv
cc: error: unrecognized command-line option '-mthumb'
gmake[2]: *** [zephyr/arch/arch/arm/core/aarch32/CMakeFiles/arch__arm__core__aarch32.dir/build.make:75: zephyr/arch/arch/arm/core/aarch32/CMakeFiles/arch__arm__core__aarch32.dir/cpu_idle.S.obj] Error 1
gmake[1]: *** [CMakeFiles/Makefile2:2814: zephyr/arch/arch/arm/core/aarch32/CMakeFiles/arch__arm__core__aarch32.dir/all] Error 2
gmake: *** [Makefile:91: all] Error 2
FATAL ERROR: command exited with status 2: /home/pi/.local/bin/cmake --build /home/pi/zephyrproject/my_blinky/build
Here's my CMakeLists.txt file:
cmake_minimum_required(VERSION 3.20.0)
set(BOARD blackpill_f411ce)
#include($ENV{ZEPHYR_BASE}/cmake/app/boilerplate.cmake NO_POLICY_SCOPE)
find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
project(zblinky)
target_sources(app PRIVATE main.c)
What is going wrong?


alt.mcarter@...
 

I'm trying to build a project. I'm getting:
 48%] Building ASM object zephyr/arch/arch/arm/core/aarch32/CMakeFiles/arch__arm__core__aarch32.dir/cpu_idle.S.obj
cc: warning: '-mcpu=' is deprecated; use '-mtune=' or '-march=' instead
cc: error: unrecognized argument in option '-mabi=aapcs'
cc: note: valid arguments to '-mabi=' are: ms sysv
cc: error: unrecognized command-line option '-mthumb'
gmake[2]: *** [zephyr/arch/arch/arm/core/aarch32/CMakeFiles/arch__arm__core__aarch32.dir/build.make:75: zephyr/arch/arch/arm/core/aarch32/CMakeFiles/arch__arm__core__aarch32.dir/cpu_idle.S.obj] Error 1
gmake[1]: *** [CMakeFiles/Makefile2:2814: zephyr/arch/arch/arm/core/aarch32/CMakeFiles/arch__arm__core__aarch32.dir/all] Error 2
gmake: *** [Makefile:91: all] Error 2
FATAL ERROR: command exited with status 2: /home/pi/.local/bin/cmake --build /home/pi/zephyrproject/my_blinky/build
Here's my CMakeLists.txt file:
cmake_minimum_required(VERSION 3.20.0)
set(BOARD blackpill_f411ce)
#include($ENV{ZEPHYR_BASE}/cmake/app/boilerplate.cmake NO_POLICY_SCOPE)
find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
project(zblinky)
target_sources(app PRIVATE main.c)
What is going wrong?