HCI Driver not registered on the ST SensorTile.box #stm32 #hci #bluetooth


Garrett
 

Hello y'all.
Looking at the supported board docs for the ST SensorTile.box it seems like zephyr should support bluetooth on this board. However, when I try and enable bluetooth (using bt_enable(...)) I get back "bt_hci_core: No HCI driver registered" and "main:Bluetooth init failed (err -19)". I believe I have my config set up correctly but I'm not 100% sure.

I have also tried other samples in the zephyr repo to no avail.

Any thoughts or ideas on how to resolve this would be greatly appreciated.

Thanks, Garrett


Erwan Gouriou
 

Hi Garret,

Unfortunately no, BT is not enabled on this platform.
Actually the bluetooth application processor (BlueNRG-M2) is not ported in Zephyr yet.
This might not be a major work as it would consist inĀ enabling communication between
Zephyr BLE host and BlueNRG controller, using existing hci over (spi/uart ?) driver.
Apparently, no one took the time to do it yet (or succeeded to do it).

Cheers
Erwan




On Wed, 8 Sept 2021 at 22:01, <garrett.battaglia@...> wrote:
Hello y'all.
Looking at the supported board docs for the ST SensorTile.box it seems like zephyr should support bluetooth on this board. However, when I try and enable bluetooth (using bt_enable(...)) I get back "bt_hci_core: No HCI driver registered" and "main:Bluetooth init failed (err -19)". I believe I have my config set up correctly but I'm not 100% sure.

I have also tried other samples in the zephyr repo to no avail.

Any thoughts or ideas on how to resolve this would be greatly appreciated.

Thanks, Garrett